4

So I just rooted my Concord II, and installed Link2SD. I partitioned my SD card with MiniTool, and made a Fat32 and a ext2, both primary. But when after opening Link2SD and giving it root access, it gives me a popup saying select the file system of your SD card's second partition (see first screenshot below), and I select ext2 and press ok. But then a mount script error popup comes up saying mount script could not be created (see second screenshot). The error is "mount: Operation not supported on transparent endpoint". How can I fix this? These screenshots illustrate what's happening:

Screenshot Screenshot

4

Try with an ext4 partition.

From www.link2sd.info/faq. I had the same issue and this fixed it.

0

Install SDFix: KitKat Writable MicroSD from the Google Play Store.

Then, using the latest Link2SD, format your flash in ext4.

  • 1
    Thanks, but will this work even if I'm on android 4.3(Jellybean)? SDFix seems to be to fix an issue introduced from Android 4.4 and up, so what effect would it have on my Concord? – Mikey S Apr 19 '15 at 20:30
  • @MikeyS Probably not. That Kitkat issue wasn't there before Kitkat, so a fix for it wouldn't find anything to fix. It either wouldn't run at all, or change nothing relevant. – Izzy Apr 22 '15 at 15:13
  • @Izzy Yeah, thats what happens, after pressing run, I get an error saying "Update failed, platform.xml file could not be updated" :( Is there another solution to this problem? – Mikey S Apr 23 '15 at 17:59
  • No idea. I have you tried to google it and find many posts for exactly this device – but all of them must be yours. Is there any forum you missed? ;) – Izzy Apr 23 '15 at 18:09
  • Lol, well I really want to get this fixed :p – Mikey S Apr 24 '15 at 0:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.