Recently I found a surprise on my Android notifications bar, telling me that the SD card is removed.

I unplugged it and plugged it again but it didn't work. I rebooted the device; still not working.

I tested it on my laptop, and in another device. The SD card is detected and it's working just fine.

I tried my friend's SD card but it also couldn't be detected!

By the way I bought this Spica last year and I never had an issue with the SD card before.

Finally and desperately I formatted it to Ext2 format on my laptop, and it still doesn't work on the Spica.

Any one have this issue before? How to deal with or how to fix it?

  • 2
    You should format it FAT, not EXT2. Jun 8 '11 at 14:46
  • I formatted it every format possible still undetected,I think I'll just slap it against the wall :)
    – HXH
    Jun 21 '11 at 16:58

Do like this:

  • Perform a factory reset from
  • Wipe the Dalvik cache as well
  • Reboot the device

If this doesn't work then format the SD in the computer with FAT 32 and create partition Ext 2 in the Recovery.

This should work...

  • Unfortunately it didn't work @blazingfinger
    – HXH
    Jan 27 '12 at 10:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.