I'd like to activate LTE on my device: S4 mini with LTE (GT-i9195). There seems to be ways of doing this, but they seem rather "scary" and experimental at best:

Is there are a better or "official" way of activating LTE on this device??

4 Answers 4


Call the Service Menu : with *#0011# and then hit (menu) Back and then (menu) Key Input and enter Q0000 and wait.

Select UMTS -> Debug Screen -> Phone Control -> Network Control -> Band Selection -> Automatic Done.

May be restart the phone.

  • This worked for me, but I had to power off and on again. Jun 9, 2016 at 16:55
  • Worked for me after I had accidentally clobbered my settings on my S4 mini. I didn't have to restart the phone - as soon as I completed the last step SMS messages started to arrive. My phone is a refurbished unit that seems to have started life as an AT&T (possibly locked) phone. As a result I can't update android (it keeps trying to get the update from an AT&T server and fails), and there are some cells it won't work in.
    – rossmcm
    Jan 14, 2019 at 0:48
  • This worked for me - i can see the 4G icon when not on wifi. However, in Settings > More networks > Mobile networks > Network mode, there is no new item like 4G or LTE,..it is still selected at 3G/2G (atuo connect).
    – smido
    Jul 13, 2019 at 20:02

Here's what I did in my dual sim J1, trial and error...I entered Q and numbers and it didn't bring up DEBUG MODE so I went in Menu > Select> I entered row number 1 and it brought up the Debug mode. So I followed it up to Debug Screen -> Phone Control -> Network Control -> Band Selection. It had for sim slot 1 and 2, I selected sim 1 and it had LTE 1 and 2. Activated LTE ALL for 1 and LTE40 for 2 (LTE 40 was the only option for LTE 2). Sim 1 went out of service so I waited, then restarted phone then both sims wouldn't work anymore. I didn't tamper with SIM 2 by the way.

So be careful...looks like phone is bricked or something now.

  • 1
    Not a brick. in theory, you can just bring DEBUG MODE back up and undo the changes to the bands. +1 For experimenting
    – Dan Brown
    Oct 17, 2016 at 8:53

There's nothing scary about that, as long as you keep track of what you're doing and not pushing the wrong buttons. Are you sure your provider even offers LTE? Also, I don't think the 4636 works on that model. You probably need to navigate through the Service Menus with *#0011# and then hit (menu) Back and then (menu) Key Input and enter Q0000 and wait...

Now, depending on where you bought you phone (EU, US etc), you'll have full access to hundreds of ways to mess up your phone settings and even brick your phone. So I can't tell you how to find the LTE specific menu. But there are several LTE related items in the CDMA sub-menus.

EDIT: 2015-03-12

For a more technical hack for enabling LTE bands, please see the following two XDA posts (and threads) here and here. Please note that this involves using Qualcomm QPST and QXDM diagnostics tools.

EDIT: 2015-09-21

You need to be rooted. The easiest way to do this, is by these 2 steps:

1) from a root command line (shell).

$ su
# setprop persist.radio.lteon true

2) Then go to the Samsung Service Mode menu, by dialing the shortcut *#2263# (BAND). There you select LTE Band Preference and then LTE ALL. (To undo, either select "Automatic" or "WCDMA Band Preferences" -> "WCDMA ALL".) Finally reboot your phone.

If these doesn't work you may also try dialing *#58366#* (LTEON).

  • It's scary. Fear of bricking or breaking your (subjectively) expensive device can be a dealbreaker for experimentation. If $$ weren't a limiting factor and hence devices were ample in supply: no fear of course... Mar 11, 2015 at 9:15
  • What is more concerning is why you think you have to activate LTE, if you already bought an LTE enabled phone? I still think this is a problem of your network provider not having it activated. You might need to get an updated SIM card from them. Do ask them about this.
    – not2qubit
    Mar 12, 2015 at 13:50

I use *#0011# Then press menu -then press back Then press menu- then press key input Type Q1187245 and enter to activate lte only Or Type Q1187211 and enter to set automatic It takes a few seconds to respond

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .