0

I have an LG 4X HD that I usually connect to the pc via usb. I have Windows 8.1. Till yesterday, when I connected it via usb, the phone always asked me the type of USB connection (only charges, media sync, tethering usb, software lg, photocamera (ptp)). I usually selected media sync. On the pc, it appeared a new storage device (I could always browse it).

Now suddenly it has stopped to work. The phone only start charging, but don't ask me anymore what type of USB connection I want and on the pc no new storage icon appears, so I cannot browse it anymore. I used to work with this phone, that is, installing my app .apk via Eclipse (i am an android developer).

I have tried a lot of things (reinstalling usb drivers from the LG website, reinstalling LGMobile Support Tool and so on) but nothing seems to work. I have tried to install the Universal ADB Driver setup, but it doesn't work neither.

What should I do? Is the problem on my PC, my phone or both?

I have already tried to use a different usb port/cable without success. I have another android phone, an LG P690 (a bit older), and it is working both as storage and as a device to which i can install apk from Eclipse (or Android Studio, which is another development IDE). The problem is still there for the P880 (LG 4X HD) which, as i already said, suddenly was not recognized anymore. I have noted that, when i plug the P690 phone, on the 'device manager' screen appears an item 'Android device', under which there is the 'Android Platform Sooner Single ADB Interface' driver. On the contrary, when i plug the P880, nothing happens (but the phone start charging, so the usb connection should be ok).

  • Probably both. First try to use a different USB port that you have not used before, with the phone. Next you need to find the phones Service Menu where these items can be set. And if you don't knowit. Try svc usb help and see what happens. Finally check your cable! – not2qubit Mar 10 '15 at 19:35
  • What Android version are you running? And what processor does this phone use? Try the following short codes from dialer: *#7284# or *#3424# or *#0808#. – not2qubit Mar 10 '15 at 20:37
  • @user1147688.Android version is 4.0.3. – Luca Mar 10 '15 at 21:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.