I need a serious advice from android experts. When I was managing my apps space in my android phone, I accidentally crashed all inbuilt google apps like google account manager, google play services and all related apps of google. If I open any regarding app of google like play store, a popup showing google play not responding properly and google maps not responding properly. This is my problem so please help me to solve my problem.

  • 1
    What Android version are you using? Are you using a stock ROM, or a custom one? Is your phone rooted? – Aleksandar Stefanović Mar 11 '15 at 10:06
  • Try a restart. If that doesn't work, please try telling us what phone you have and what Android version you are running. – lolrepeatlol Aug 2 '16 at 23:57

Its is not necessary to fully wipe the phone. You can go to app manager and reset all google apps to their factory states and update them once they are functional. This is only for not working apps in case you did not get stuck during rooting. If in case you tried to root it, then try unrooting and rooting again and if this does not fix the problem, then do a factory reset.

| improve this answer | |
  • root it doesn't help.after flash any rom, phone need wipe for many reason ... – ʍѳђઽ૯ท Mar 11 '15 at 10:55
  • I'm unable to understand what you are trying to tell properly. Please be a bit clear. – Vihari Sindhu Mar 11 '15 at 11:01
  • Thank you. But as I remember, it does uninstall all updates of the application. I do not know a problem of moving apps except when rooted as you can move all apps to sd card. So I may not be of help now. – Vihari Sindhu Mar 12 '15 at 16:03

If you are rooted install a custom ROM and flash gapps.zip file for your ROM else you could download play services apk, a factory reset might also help. Hope this helps.

| improve this answer | |

You can try to fully remove google play services, delete any google accounts you have activated on your phone and then reinstall google play services.

I had a similar problem, and a corrupted google play service was the cause.

| improve this answer | |
  • This looks like a comment for than an answer. Please provide a how-to type of approach on your answer for it to be a good answer. – SarpSTA Mar 31 '16 at 20:37

Just wipe dalvik cache and you're good to go. Fixed it for me though.

To do that follow these steps:

  1. Turn off your device

  2. Press on/off button and volume button down on the same time (volume up/down varies for every device)

  3. You should come into the bootloader menu, go down to recovery

  4. Once you're in recovery, you'll go to the wipe tab and select "wipe dalvik cache"

  5. Eat a cookie and be happy with a working phone again

| improve this answer | |
  • Stock recoveries don't have an entry to "wipe Dalvik cache", that would require a custom recovery (or root do do it manually). – Izzy Apr 27 '16 at 10:02
  • @Izzy they do have that... all my 8 devices had it, so the chance is 100%... – Jason Apr 28 '16 at 7:08
  • None of my 10 devices had it (before I installed a custom recovery). So what does that lower your 100% to? 8 devices out of how many? To my experience, stock recovery offers to wipe cache, yes – but not Dalvik unless you could the factory-reset. Would be interesting though to know what those 8 devices were: all the same brand? – Izzy Apr 28 '16 at 7:15
  • Samsung, LG, Motorola, Xtreamer, Huawei, Sony, Motorola, HTC. 8 devices, all got standard dalvik cache wipe option. To do the percentage math: ((10 * 0 + 8* 100)/18) = 44.44% – Jason Apr 28 '16 at 9:16
  • OK, I had HTC, Motorola, LG, Samsung (phones) plus some tabbies from "minor brands" here where I didn't find an option to wipe Dalvik. Cannot check anymore as they all have custom recoveries now. Googling on the topic always says either custom ROM or using fastboot, see e.g. How to remove dalvik cache without using custom recovery (from 7/2015). So even if all your devices had it in "3e recovery" (hard to believe as it is), you cannot take it for granted all other devices have it. – Izzy Apr 28 '16 at 9:42

Try a restart. It will restart the Google Apps too, which might help.


Here's last resort if my answer or the other answers don't work -

Method One: Do a factory reset

Go to Settings > Backup and reset > Factory data reset and click RESET PHONE

Method Two: Get a custom recovery (if you don't have one already) and flash GApps

Flashing recoveries can be difficult for a novice, but if factory resetting doesn't work, then this is what you have to do.

Find out what your phone model is, then find a guide online.

Once you're done with that, boot into your new recovery if you haven't already.

Since you probably have adb configured on your PC at this point, if you have TWRP, tap Advanced, then ADB Sideload.

Click this link on your PC to download GApps. Based on your Android version (most on 5.0, but tell us to make sure) and architecture (most on ARM, but tell us your phone model just in case) and download the file. Once downloaded, rename the file to gapps.zip

Now, inside of file explorer, go to where you've downloaded the .zip. DO NOT EXTRACT.

Click and type Shift + Right Click and click Open command window here Now, type adb sideload gapps.zip. It might have to load, if it doesn't show that it has sideloaded but only started adb up, try the command again.

Once done, reboot the device. You're done!

Once again, I am not responsible for what happens on your phone with this method.

| improve this answer | |

If you cannot find a gapps package for your device, and clearing data on "Google Play Services" and "Google Account Manager" doesn't work,

Your last resort would be to do a Factory Reset:

  1. Backup your data manually, by copying your pictures to your SD card or computer, then using the adb backup command if you care about your app data. If you want to keep your text messages, export them via SMS Backup & Restore if your Messaging app doesn't have a built-in backup function.
  2. Go to Settings.
  3. Then scroll down and click on "Backup and Reset".
  4. Uncheck Back up my data and Automatic restore.
  5. Press "Factory data reset" and Confirm
  6. Wait for device to reboot
| improve this answer | |
  • 2
    What do you mean with this? Do you think the answer is factory reset? Then please state it first and share your opinion on why it might be the reason. – SarpSTA Mar 31 '16 at 20:37
  • The question was asked 1 year ago. However, I can see how this would be useful for future Googlers. – Aaron Gillion Mar 31 '16 at 23:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.