Hardware : MT6582
Model : XOLO One
Build number : XOLO_One_S006_14012015
Build date UTC : 20150115-031031
Android version : 5.0
Baseband version: SKY77590_GSM4_W4_MT6582_MP_V1.0.2_S0105, 2015/01/05 13:42, 2015/01/05 13:42
Kernel version : 3.10.54 (jenkins@80-32) (gcc version 4.8 (GCC) ) #1 SMP Thu Jan 15 11:22:17 CST 2015

Description:- I tried everything (Framaroot, kingoroot, iroot) but no progress, can't root it at all. I am not an expert.Is there anyway out ? When I bought the phone it was running on Kitkat and was rootable because one of my friend did it. But after updating to Android 5.0 it seems there is no way out. Few things that I found while trying to root it :-

-File /system/recovery-from-boot.p which restore factory recovery in case of phone switching on in a normal mode Is Found.


1 Answer 1


You can root XOLO phones using Framaroot application. The framaroot application helps to install the Superuser and su binary on the android phones (but compatible only for few android devices).

Before Proceeding:

1.Take a full backup of your phone by using appropriate backup applications.

2.Once you have backup your important data’s which was available in your phone, check the battery level of your phone.

3.Incase, if it is low charge them fully, so then it never get switched off during the middle of the rooting process.

1.First, download the framaroot.apk from this page of xda-developers.

2.Once you have download this application install the same in your device.

3.After that select the SuperSu from the dropdown menu.

4.Select the Boromir now and reboot the phone.

5.That’s it! Now, your phone has root access and you will get success message which implies The SuperSu and Su binary was installed.

6.After seeing this message on your mobile, just reboot your phone.

  • in the question: "I tried everything (Framaroot ..." Mar 11, 2015 at 20:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .