0

I am trying to root a Samsung Galaxy 4 tab 7". The box says SM-T230NU with a label "Model: SM-T230NYKMXAR".

I got drivers from here:
http://www.samsung.com/us/support/owners/product/SM-T230NYKUXAR
which is slightly different number (has a U instead of M) but matches (ie. Samsung Galaxy Tab® 4 7.0 8GB, Black). I installed these and the device connected to the PC with no problems.

Using Odin 3.07, it detecets the device. I click the PDA button and select CF-Auto_Root.tar, then Start and I get this error:

Firmware update start..
recovery.img
NAND Write Start!!
cache.img.ext4
FAIL!
All now when I restart I get this message:

Now when I restart I get this message:
Firmware upgrade encountered an issue.
Please select recovery mode in Kies & try again.threads completed. (succeed 0 / failed 1)

I downloaded and installed Kies 3. When I run it it says "The connected device is is not supported by Kies 3".
It should be, this is 4.4 KitKat

So I tried Kies 2.6, and it doesn't connect either. It doesn't give this error message, just keeps trying to connect but doesn't.

What can I do now?

  • Which CF-AutoRoot did you use? There's no official AutoRoot for that device on Chainfire's website. Also, did you unlock the bootloader first? – onik Mar 11 '15 at 13:37
  • I used the CF-Auto-Root.tar that came in the Odin zip file. I don't know what you mean by 'unlock the bootloader'. I put the device in developer mode and checked USB debugging. Is that it? – Al Lelopath Mar 11 '15 at 13:51
  • Where did you get the zip from? Was it specifically for T230? Unlocked bootloader is a different thing and it's needed for CF-AutoRoot if used via Odin. See the XDA Wiki for more info on bootloaders. It seems like CF-AutoRoot attempted to flash your cache but failed, and you'll need to flash back to stock before trying anything new. – onik Mar 11 '15 at 13:58
  • >>flash back to stock before trying anything new ... how do I do this? – Al Lelopath Mar 11 '15 at 14:41
0

Flash your stock ROM using Odin whilst your device is in
Download mode Power + Volume Down + Home

(Put the file in the AP/PDA depending on what version of Odin you have). If this works then your tablet may be back to factory state, but if it fails then you have Hard bricked your tablet. Presuming it isnt bricked, use the latest .apk file of King Root to root your Sm-T230.

Stock Rom Download from XDA forums: ACHERON ROM v2.1.1 and Odin 3 download

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.