I have purchased a Kindle Fire HD 2. Generation (2012) and wanted to root it. I followed the instructions from Rooting a new Kindle Fire HD and and other instructions found via google. When I run the Bin4ry version, the pad is really slow afterwards for some reason. I found this thread here, but it's not really helpfull.

I also tried the Qemu version, but this also doesn't work. The only thing this resolves is that it runs at normal speed after it's done, but the device is not rooted.

So are there any tips on how to do this? I would like to get Google Playstore running, instead of being chained to Amazon. All information I find with google leads me back to the same solutions which don't work.

  • Please see Rooting a new Kindle Fire HD, which covers the 7" and 8.9" variants.
    – Izzy
    Commented Mar 11, 2015 at 16:27
  • I even linked to this post in my question, because it simply doesn't work.
    – Devolus
    Commented Mar 11, 2015 at 17:57
  • 1
    what doesn't work? are you on OS version 8.4.3? Are you getting error messages when following the steps in the answer that @Izzy linked (and that you linked)? Commented Mar 11, 2015 at 18:26
  • It's not rooted, which is what doesn't work. I checked my version and found out it is 8.5.1, so it seems that these solutions don't work there. I found some rootkit, whcih I will try tomorrow, whcih hopefully can do it.
    – Devolus
    Commented Mar 11, 2015 at 21:55

1 Answer 1


My Kindle OS is 8.5.1 where the above solutions don't work (nor any other I found via google).

However, I found a thread on xda developers which pointed to a file name root_master.apk and this one successfully rooted my device.

When using this apk, the process was partially in chinese (which I don't understand), but it worked. Not sure if this app is safe though, so use at your own risk.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .