1

After my Android Lollipop upgrade on my HTC M8, some apps are unable to access the internet such as Twitter, but Facebook works perfectly fine. WhatsApp works fine except that I'm unable to receive Media files as well. This only happens with Wi-Fi.

I tried forgetting the network, rebooting the device, turning Wi-Fi, and even hard reset my phone. I reset the modem and done almost everything. Nothing works though.

None of this happened before the update, one more thing is that it only happens with my Home Wi-Fi, other Wi-Fi networks work perfectly fine.

I tried connecting other phones to my home Wi-Fi, and it works perfectly fine.

How can I solve this?

  • I have this same problem actually. – Math1000 Mar 13 '15 at 11:28
0

It's a DNS problem. Try using Google's DNS.

Go into your router's advanced setup and change the primary DNS server to 8.8.8.8.

  • 1
    That isn't exactly feasible at work... – Math1000 Mar 13 '15 at 11:29
  • You can set the dns in Android device in each wifi advances settings but it pairs with static IP :( – madlymad Mar 14 '15 at 23:54
  • Needs a user name,host name and a password? ON THE ROUTER. – Krayem Mar 15 '15 at 17:11
  • EDIT: EVERYONE WHO IS EXPERIENCING THIS ISSUE: I Changed the DNS in my Router Setting and my android,nothing worked but after i rebooted the router BAM,it worked. FINALLY,this has been such an annoyance after 3weeks. Thanks Matthew. – Krayem Mar 15 '15 at 17:37
0

Google voice typing didn't work suddenly one day, so I tried swipe/dragon and it said I had no internet connection, try again later. This suggested some intermediate problem on the device. I had 3 bars of 4g and a functioning wireless, so figured it was a software problem. After much digging it appears that S Voice had updated itself without telling me, and I hadn't ticked the box to accept terms and conditions, nor had I given it a wake-up command. Once this process was completed, all back to normal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.