I have Sony Xperia Z2 with Cyanogenmod 1220150305

I cannot boot into any recovery based applications.

I have tried with the phone off and the down and up volume buttons, I have tried with apps that reboot to recovery, I have tried with the advanced power button on CM, I have tried with adb reboot bootloader/recovery and I have tried by just trying to install an update from the CM Updater.

What do I do to get this into Recovery? Otherwise the phone is fine, but it now means I can never update the phone ever again which I am not happy about as this version of CM12 is not great.

3 Answers 3


Turn off your phone and let it stay like that for 20 seconds Then try the key combination again until the led goes blue (from pink)

If that doesn't works Try flashing the cwm recovery image again manually using

fastboot flash recovery nameOfTheImage

Or follow this link to download the boot.img file and flashing it via

fastboot flash boot boot.img

Link:- http://techbeasts.com/install-cwm-recovery-root-xperia-z2-2301a0167-d6502-d6503-d6543/

Hope this helps!


turn off your phone completely and press volume- and powerbutton togethor for fewsecond. Your phone will get into recovery mode

  1. Settings> System> Developer options
  2. Check 'advanced reboot'
  3. Power button> reboot
  4. Boot screen should show you an option to go into recovery.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .