6

I have turned off WIFI in the settings, but it's still always running. Doesn't this graph indicate that WIFI is really on all the time? How can this be when it's definitely "off" in Settings?

I'm worried that this constant WIFI use drains my battery and I want to avoid this.

This is a Nexus 4 running Kitkat 4.4.4.

I have also installed the Llama automation app which can optionally turn on WIFI every x minutes, but I have made sure that option is definitely turned off. This behavior continues even when Llama is not running. I don't think there's any other app on my phone that would have the capability to turn on WIFI on its own.

Is there some way I could find out whether one of the installed apps is responsible for this?

enter image description here

4 Answers 4

1

Android is automatically keeping Wi-Fi on while the phone is sleeping (Keep Wi-Fi on during sleep) and always scans for available networks (Scanning always available). They must be keeping it on. Try disabling them from Settings > Wi-Fi > Advanced.

4
  • Yes, this setting was on "Always". I've switched it to "Only when plugged in" now. (If "Always" is the default value, then the chart doesn't really make any sense, does it?) Commented Mar 13, 2015 at 16:05
  • On the chart, the Wi-Fi should be always displayed as working when set as default, I don't know why "Always" is made the default value.
    – aastefanov
    Commented Mar 13, 2015 at 16:08
  • 3
    This setting should only matter if Wi-Fi is enabled, whereas OP seems to indicate that they've disabled it. Commented Nov 2, 2015 at 18:06
  • 1
    "Scanning always available" seems to be more of an issue, "Keep Wi-Fi on during sleep" should only matter if you have manually enabled the wifi, so it's ok imho Commented Jan 14, 2016 at 9:55
1

WiFi always on is caused by you granting access googleto always being able to check for WiFi at any given time in googles point of view that means ALWAYS You can disable it by going to your GPS settings and clicking the 3 dot menu > advanced unchecking the WiFi scanning hope this helps

1

Found the solution. Go to location. Select scanning options. Disable Wi-Fi and Bluetooth scanning. Problem solved.

0

I found that Spotify or any media related control app seems to always be chatting over the network keeping it awake and active.

A Google Home assistant type device like Home Mini can cause the same issue, especially with the 'Let others control your cast media' option.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .