I cannot see exchange account option on gmail add account. Gmail version 5.0.1. How to rectify this?

  • The Gmail app DOES support Exchange, but it appears to be only on Nexus devices running Lollipop. I believe you can install the .apk manually, if you search around for it. Haven't tried it myself yet, but considering it.
    – user98603
    Commented Mar 18, 2015 at 8:06

6 Answers 6


Gmail 5.0 added support for Exchange accounts, but it requires an additional APK (Exchange Services) which you can't get from the Play store unless you already have it. As one of the other answers indicates it seems to just be with Nexus devices at the moment (maybe some newer Lollipop ROMs do for other devices, not sure).

However, you can sideload it! I just did from APK Mirror (using this version) and after fully closing and restarting Gmail I had the option to add an Exchange account.

  • Thank you @Matthew Read, it worked like a charm for my Motorola Moto G 1st version. :) Commented Jul 9, 2015 at 7:52
  • 1
    This worked on a Nexus 5 running 5.1.1 imgur.com/ZIduwvS Commented Aug 27, 2015 at 22:03
  • Works on LG G2 with KitKat (stock rom)
    – Mando Stam
    Commented Nov 6, 2015 at 7:13
  • Works on One Plus One too! Commented Nov 30, 2015 at 23:15
  • Worked on Samsung S7
    – dten
    Commented Mar 10, 2016 at 7:25

Please check to make sure you don't have any disabled apps.

Go to Settings > Apps > go all the way to the right-most tab. If you have any disabled apps, there will be a tab called "disabled." If there are no disabled apps, there will be no tab. If you see anything related to exchange, please re-enable it.

  • Not sure why this got downvoted. It's not THE answer, but it is an answer that might be a solution for some users. Commented Dec 30, 2015 at 18:38

I was having this same issue and found by doing the following was able to resolve. Goto Settings-->Applications-->Application Manager-->Scroll all the way to right side should be column ALL-->Select Gmail application, clear cache--> Go back to ALL column and search for Exchange Services-->Select Force Stop. Re-open Gmail App and should be good to go!


Re-enabling the Exchange Services is tricky as system services are not visible by default.

  • Settings → Applications
  • "..." (action overflow button in top-right) and enable System apps
  • Go back to the list of apps, find Exchange Services, and activate it.

To make sure everything was fine, I also uninstalled and re-installed the GMail app (although this was probably unnecessary).


I had the same problem on my Nexus 10 with Android 5.1.1. I Couldn't create a new Exchange account; the option wasn't even listed. It used to work in the past.

I followed Mike's advise and first disabled my Exchange service after clearing it's cache. It then asked me if I wanted to reinstall the stock exchange service, which I did. After that I enabled the service again. Started Gmail, and it worked; It finally listed the option and I could make a new Exchange account.


The Gmail app does not support Microsoft Exchange.

To add an Exchange account go to Settings> Add Account > Corporate

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .