I want to install a custom ROM in my Xperia ray. I have rooted my phone, unlocked the bootloader, and also installed ClockworkMod recovery. I have downloaded the custom ROM and Gapps on my SD card. But I am not able to enter recovery mode. I am always sent to safe mode.

I have tried the first two pages on google but had no success.

Please help.

  • Check your ClockworkMod recovery installation. Have you edited the permissions of CWM files once you've copied them into the system? Mar 15, 2015 at 12:50

2 Answers 2


TWRP recovery with modified kernel I was unable to boot into recovery mode, when trying to root my Sony Xperia Z5 for the first time.

It worked after modifying my Android 7 Nougat kernel with this tool: https://forum.xda-developers.com/xperia-z5/development/root-automatic-repack-stock-kernel-dm-t3301605

After that I had to but also could enter recovery mode via "adb reboot recovery". Which then worked well for me.

Trying to install lineageos... .zip, the check for right device was wrong in my case.

Installing zip file '... .zip'
Checking for MD5 file...
Skipping MD5 check: no MD5 file found
E3004: This package is for device: E6633,E6653,sumire,sumire_dsds; this device is .

E:unknown command [log]
Updater process ended with ERROR: 7
Error installing zip file '....zip'
Updating partition details

It can be changed easily as desribed here: https://forum.xda-developers.com/showthread.php?t=2522762

Worked well for me.


Download Android Studio, install ADB SDK, then open command prompt, change directory to


Then hit the following in command prompt

adb reboot recovery

Then your phone enters recovery mode. I did the same in my Xperia Ray and succeeded.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .