I upgraded yesterday to Android 5.1. Looks awesome but thinks that my home internet wifi is not responding and won't connect to it anymore. (Give me an exclamation mark on wifi.) The new feature (stop trying to connect to networks that aren't responsive) they added to wifi is clearly acting up. I can connect through multiple other devices to the same wifi without issue.

It does get an IP address and my phone is still able to connect to my work wifi. If I go into my saved connections after a minute, that is where it tells me that its not getting connectivity and will no longer try to connect to that network. I did try rebooting the phone.

Any idea's of other things I can try to make it connect to my home network?

up vote 1 down vote accepted

I had the same problem, but after upgrading to 5.02 I solved it by removing the network (go to WLAN settings and long click your home WiFi and then select remove) and then reconnecting to it. It will ask you for the password again and after that it should connect normally.

I heard that there are some WLAN bugs in Android 5.

  • I did this like 5 times and rebooted the phone, but after going to work connecting to a different network then doing this... it finally worked. – Matt Andruff Mar 25 '15 at 15:10

I had the same problem. I updated to Lollipop 5.1 yesterday. Today, my wi-fi connection suddenly stopped and went to this infinite loop with the message "Obtaining wi-fi address". Some people said that I should switch to Static IP in advanced settings, didn't work for me.

My solution was: simply reboot your router.

I had the same problem after 5.1 OTA update on a Nexus 4: wifi would no longer auto-connect to known routers.

Work-around for now: installed Wifi Switcher which forces the phone to connect automatically, but only to the strongest signal, which is usually the one I want.

Still waiting for a fix from Google.

protected by Community May 19 '15 at 18:17

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.