0

I have a Micromax Canvas 2.2 A114. I recently flashed a custom ROM and it was working pretty well.

Recently, I tried to install Xposed Framework, my phone was stuck in bootloop after the reboot process. I removed the battery and put it back, it was again back to normal.

So, I tried to enter CWM recovery, but instead my phone booted up and everything was factory reset. Now, whenever I try to enter recovery mode, my phone gets factory reset. Even if I charge the battery and then reboot, same thing happens.

What should I do? How to enter CWM recovery or charge my phone without factory resetting/rebooting my phone?

I want to flash the Custom ROM or Stock ROM again but how to do it without getting into recovery mode.

Please help me.

  • 1
    You can flash your Custom/Stock Rom through fastboot method. You don't need to enter into recovery. You need to download fastboot image of Custom Rom. In fact, you can flash CWM recovery (try updated one) from fastboot too. I would try flashing it first if such an issue occurs to me. Besides, if its Micromax then definitely its Mediatek processor (except yureka) and so, you can also try SP Flash Tool to flash without using any fastboot command or something. – Firelord Mar 22 '15 at 12:26
  • I have no ROM presently in my mobile. All I can do is enter CWM. When I select fastboot mode using the power+vol button, it shows >> FastBoot Mode. That's it. Nothing else. How to use fastboot to flast CWM again and then the ROM? Is that something to do with ADB? – Aadharsh Krishnan Jun 15 '15 at 14:13
  • Also, how can I get a fastboot image of the ROM and CWM? Is there something I should do to get it? Sorry for being a noob but please explain in layman terms. – Aadharsh Krishnan Jun 15 '15 at 14:15
  • Here are some helpful instructions. – Firelord Jun 15 '15 at 16:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.