11

I was trying to secure me phone. I had turned on pattern. Then thought for extra security I would turn on Smart Lock. Note the pattern lock is gone. I want to feel that I can leave my phone on the coffee table and walk away.

1
  • 1
    You can just turn off from the same menu when you set Smart Lock: Settings - Security - Smart Lock, then remove any lock set, including turning off On-body detection*
    – Andrew T.
    Dec 21, 2015 at 14:02

2 Answers 2

21

Go to Settings—Security.

Under Advanced, tap Trusted agents as shown below.

Tap Smart Lock (Google) to Enable\Disable it. You can also drag the switch to the Right\Left side to Enable\Disable it.

Setting\Security\Trusted Agents SmartLock(Google)

3
  • Don't forget to Click the grey ☑ at the left of this text, which means this answer is valid, as regarding to android.stackexchange.com/help/accepted-answer and android.stackexchange.com/help/why-vote May 18, 2016 at 11:01
  • Not so great UX, Google. It's not easy to turn off this annoying feature. Jan 9, 2019 at 17:43
  • This was driving me crazy - my home is 'known' by google, which is ok for maps; but it's automatically a trusted place, unlocking my phone at home (which I don't want). Most posts say to remove the place, but it reappears within minutes. This was how to shut it off completely.
    – goodeye
    Feb 14, 2020 at 3:37
2

You can turn it on and off in Settings -> Security -> Trust agents

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .