0

I just bought a G2 on craigslist. It came rooted and with custom recovery. Whenever I plug it into my computer (tried my mac and two other PCs) the phone does not recognize it's plugged into a computer (just gives me a regular slow charging warning). On windows when I plug it in I get a malfunctioning usb device error. I have tried many cables.

I have USB debugging enabled.

I also tried putting it in download mode, but it still gives the malfunctioning usb error and the progress bar never goes anywhere.

I think the device is missing a recovery partition (might be something I did while trying to fix it) because I can't seem to get into recovery.

Is this a hardware issue or what?

0

Have you tried checking the device manager on your PC? you might need to install some software to have it work. However you just use Wireless Storage and type in \G2 in networks to access it.

  • Turns out it was a hardware issue..yaay. – TheN33k Mar 24 '15 at 17:47
0

What OS is it running? Knowing that might help. My former device was an LG LS860 (Mach, Cayenne), with ICS 4.0.4 installed. Could not use the external micro-usb storage device just bought. Long story short, went to Google Play Store, downloaded a USB OTG detection app, nothing was found. Turned out that either LG or Google left that feature out. Researched it further and learned that rooting might work. Afraid I could brick my phone, decided to live with it. A viable workaround would be to transfer files via wi-fi or Bluetooth. If no Bluetooth hardware on your computer, get a dongle to plug into the USB port. It should work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.