My Nexus 5 upgraded from Android 4.4.2 to 5.1 now it won't connect to mobile data.

How can I get it to connect?


You're not the only one: google support forum issue.

Seems to happen after mobile data has been unused for a while - ie when you come off Wi-Fi.

Comes back if it reconnects to the network.

Workaround 1 - Toggle Airplane mode on and off

Workaround 2 - in Settings -> More -> Cellular Networks -> Preferred Network Type. Change the setting, then change it back.

Workaround 3 - go out of mobile range (no signal)


This worked on my Doogee Valencia2 Y100Pro

  1. Install and Open app "Hidden Android Settings" (by 0Alex)

  2. Select choose and open "RadioInfo"

  3. Move to Last option "TOGGLE DNS CHECK"

mine read " not allowed"

press the "TOGGLE DNS CHECK" so that it displays " Allowed"

That's it - my mobile data worked, I hope it works for you


You should try this: go to Settings → Mobile network settings → Access point names → click the dots on the upper right hand corner → select Reset to default.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.