1

I was making an Android app that sends data using Bluetooth. My internet was working fine until I started using my app on the phone. I noticed that the WiFi would randomly disconnect (the WiFi icon in the status bar disappeared). Weird. Now, the phone refuses to connect to the internet.

Here is what I did so far:

  1. Switch off the WiFi and turn it back on.
  2. Restart my phone.
  3. Power off, wait, power on my phone.
  4. "Forget Network" and then connect to my home network, again. Ironically, my phone authenticates with the home router but refuses to connect to the internet. It even refuses to connect to 192.168.0.1 which is the IP of the home router with which it just authenticated.

Chrome says that 192.168.0.1 is an unreachable address but the phone is assigned 192.168.0.101 as the address which means they are on the same network.

Can someone please tell me what is going on?

Stock ROM, Galaxy S3 International Edition GT i9300. Mobile data works flawless.

Update:

Iface   Destination Gateway     Flags   RefCnt  Use Metric  Mask        MTU Window  IRTT                                                       
wlan0   00000000    0100A8C0    0003    0   0   0   00000000    0   0   0                                                                              
wlan0   00000000    0100A8C0    0003    0   0   312 00000000    0   0   0                                                                            
wlan0   0000A8C0    00000000    0001    0   0   0   00FFFFFF    0   0   0                                                                              
wlan0   0000A8C0    00000000    0001    0   0   312 00FFFFFF    0   0   0                                                                            
wlan0   0100A8C0    00000000    0005    0   0   0   FFFFFFFF    0   0   0                                                                              
  • Have you grabbed the default route with your bluetooth app? – ott-- Mar 23 '15 at 18:24
  • @ott-- what is that? :/ – Little Child Mar 23 '15 at 18:25
  • Open a terminal, run cat /proc/net/route and paste the output here. – ott-- Mar 23 '15 at 18:34
  • @ott-- check update. I even tried FXR WiFi fix but to no avail – Little Child Mar 23 '15 at 18:40
  • @ott-- I used 00001101-0000-1000-8000-00805F9B34FB as my UUID in my app. I can make a GIT repo of the source if you wanna see. – Little Child Mar 23 '15 at 19:02
1

This is sometime because your phone save the paswrd of your wifi and sometime it doesnt connect it just show this that it is connecting to but does not become successful in doing so . . . . so remove or forget your wifi connection

restart you phone

and try to connect again with that wifi

may this can help you

worked fine with me many times

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.