1

I'm trying to unlock a Samsung Galaxy S3 Gt-i9305 on EE running Android 4.3. I know how to unlock the phone however, when I connect the phone to my computer it does not appear at all. Usually, Android phones have a notification saying the phone is connected as a media device or something but it doesn't appear.

I've tried this on Windows 10 technical preview and Mac Yosemite. I've tried the following:

  • Installing new drivers (however I don't know if they were the correct drivers I tried several though)
  • Installing Kies and updating to the latest version on both Mac and Windows
  • Putting my phone in download mode to download drivers (no drivers downloaded)
  • Restarting the phone and taking out the sim

Is there anything else I can possibly do? Is it a hardware problem? I don't have USB debugging on either. Thank you for your help.

EDIT

I've tried different USB ports, they work with my S4 but not my S3

0

I had the same problem of not having my device appear on my Mac running OSX Yosemite. The only difference is that I am using a Galaxy Note 3. What made it work for me was to change the USB port. I think it may have to do with the COM port not automatically selecting or something similar.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.