1

I have zenfone 5 (A501CG) with Kitkat 4.4.2. When I connects mobile to my laptop it shows popup saying that "USB device not recognized. the previously connected device is malfunctioned". To solve this problem, i have did following:

From control panel->hardware and sounds->device manager. there is one device named ** Unknown USB Device(Device descriptor request failed

Here i have updated device driver it says that "device driver is up-to-date". But problem is still there. Can anybody please help me?

  • I'm not a Windows guy, but have you tried to remove that "unknown device" from the device manager (while your Zenfone is disconnected), and then connect the Zenfone again? If that fails as well: Remove it again, check for the drivers from Zenfone, install those, and then connect it again. – Izzy Mar 25 '15 at 15:46
  • Try changing your usb cable and then try – Vivek Mishra Jan 21 '16 at 8:50
  • I know this could be stupid to ask, but did you mind cleaning the phone USB connector? Windows don't recognize it could be because of durt or something. – esQmo_ Oct 21 '16 at 3:38
0

On your smartphone:

Go to Settings -> Storage -> Click on the USB icon (Near of the clock) -> Mark Media Device (MTP).

Then wait a moment and this should work.

  • yes I have tried this but still problem...along with this I have turned on "usb debugging" from "developers options".. actually smartphone is not able to connect with any laptop so i guess problem is within phone itself. – VaibhavK Mar 27 '15 at 16:50

protected by Community Jun 3 '15 at 19:46

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.