6

I have a Nexus 5, all my ringtones and notification sounds returned to default, and when I try to set any file as a sound I get this message:

Wrong file type, please select again

I get the same message no matter what file type I choose, including the files that were my sounds until this morning. I tried to delete cache memory and reboot but that did nothing.

  • 1
    Maybe related: android.stackexchange.com/questions/85592/… – Andrew T. Mar 24 '15 at 8:47
  • As a temporary solution I can only suggest you get a ringtone app that allows you to set ringtones and use it just for that, I've had this issue for a while and nothing solves the actual problem. Just curious. Have you done a firmware update before the problem occurred? – Zero Jun 2 '15 at 8:19
6

José Mejuto Was correct in his 2nd Point.

deleting the /.nomedia file has no effect.

  • 1: Go to "Settings -> Apps (All) -> Media storage"
  • 2: Clear Cache & Data
  • 3: Change your ring tone or notification tone

Thanks José :)

|improve this answer|||||
  • 1
    On newer versions of Android, you may have to pull down the menu on the Apps list and select Show system in order for Media Storage to show up. – NickAldwin Jun 30 '16 at 12:07
3

Today my Nexus 5 starts to do the same, default Ringtone and "Wrong file type, please select again". After several hours trying different solutions I came to the conclusion that the problem is in -or related to- the "Google Play Music" which do not work for local files anymore. I was able to finally get my custom ring tones again to life performing two tasks, but I do not known which one solves the problem because a reboot is needed and I perform both before reboot.

1) In my case in the root of the SD card there was a ".nomedia" file which could prevent multimedia use in this folder and below. So try to delete this file and reboot terminal, then try to set a custom ring tone.

Note: My Nexus is in spanish, and options could have a different name.

2) I suspect that multimedia SQLite database was corrupted in some way, so I went to Settings -> Applications -> "Almacenamiento de medios" (Maybe Media storage? com.android.providers.media) and deleted data, then reboot.

After the reboot all multimedia data was rescanned and I was able to change the ring tone again.

Note: I had detected that my old custom tone for notifications was gone, the file was gone and I was unable to find it in my storage media.

|improve this answer|||||
0

I'm using the Moto G and I had the same problem. Solution for me was to

  1. Download a file manager app

  2. Save the ringtone mp3 file in my music folder

  3. In settings\ringtones (in the file manager), select your ringtone from the music folder.

|improve this answer|||||
0

I stayed with the original folder named "Ringtones" and just renamed it to "ringtones" [lowercase]. Rebooted. Problem Solved

|improve this answer|||||
0

Copy to existing Ringtones folder on device, go to choose ringtone and select media storage and amongst the device ringtone selection will be your file

|improve this answer|||||
0

Please change your audio file format to .wav; now you give it a try to assign the ringtone. It will work! Since, I had this same issue when I tried to assign a ringtone in an .mp3 file. Then, I changed the .mp3 format to .wav format; it works!

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.