0

I am using Samsung Galaxy Tab 3. I use it to play games and I have one that needs to be backed up by Google+. Unfortunately, my tablet doesn't have Google+ and Google Play services app installed in it. So everytime I try to sign into Google+, it always direct me to Play Store and ask me to install Google Play services.

So I did follow the steps required. I tried to install Google Play services, but it always gave an error message below.

Incompatible with other application(s) using the same shared user ID.

How to handle this issue?

error dialog

  • Whoops! Meant to say improve the answers. These seem really vague :( – Dan Brown Aug 23 '15 at 8:21
  • @DanB I clarified the existing answer. If it's still vague, please let me know which part. – Andrew T. Aug 25 '15 at 4:39
  • @AndrewT. Sure, just looking now. -Edit- could you edit the part from the comment below in? – Dan Brown Aug 26 '15 at 8:34
1
+50

The steps which I followed (when it happens to me) :

1.Backup all the data and apps you already have on your phone as we are going for a factory reset.

( To backup current version apks of the app use root explorer and copy all apks from /data/app and some apks from /mnt/asec/ )

2.Downloaded latest signed Google-Apps for your Android version (like Jellybean, Ice Cream Sandwich, KitKat etc).

  1. Turn off your phone.

  2. Boot phone in recovery mode and Wipe data/factory reset. (This is why you need to back up everything).

  3. Flash the latest signed Gapps downloaded earlier.

  4. Wipe Dalvik cache and cache partition then reboot.

  5. Download the latest version of Google Play Store and install it.

  6. Update all the Google-Apps via Play Store.

  7. Then install Google Play Services and done!

Note:- Alternatively, At step 7 you can open the Market (Play Store) and tap agree. Then press home and leave it for a while. After the Play Store is updated, open it and tap agree again. The new Play Store should download Google Play Services and install it.

  • Best one so far :) quick question, could there be an alt no root method cough adb sideload cough – Dan Brown Aug 26 '15 at 8:39
  • Also: no root option in general??? – Dan Brown Aug 26 '15 at 9:04
  • 1
    Bounty awarded. Reason: this randomly came up on my phone, doing this method worked. – Dan Brown Aug 30 '15 at 12:02
0

Steps to solve your problem:

  1. Download Google Play services APK from APK Mirror (you can use your tab for this)

    (Download the appropriate version by following the code on the Notes / What's New section)

  2. Install the APK by opening it.

    (If it gives you warning of "unknown sources", go to Settings > Security > tick "Unknown Sources")

  3. After installation is complete, update all Google apps like Gmail, Google+, etc.

  • Please download appropriate version for android system only(kitkat is 4.4.x, JellyBean 4.1.x, Ice Cream Sandwich 4.0.x) – Prachil Tambe Mar 25 '15 at 12:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.