I’ve a file called like t0.t1 t2 t3 on my Android Device.

first it had a bad name from download and I tried to rename it. Something has to gone wrong. It was o1.o2 before.

I tried to rename it to something else - only o2 should be the same and t0-t3 the name before the file ending

Now the name is like above, but without file ending.

RootExplorer shows me the file like above (first line)
the custom ROM file explorer .o2.

I cannot rename, move or delete it.

Any ideas?

1 Answer 1


You could install ADB on your computer (part of the Android SDK), plug in the device then use the adb shell to delete the offending file. Something along the lines of,

$> adb shell
your-android-device> rm '/path/to/file'
  • yes; I tried that via terminal emulator - no such file or directory (via ls I get .o2 - also that doesn't work)
    – rala
    Mar 25, 2015 at 6:40
  • Can you list it with wildcards? ls -la *.o2* (there should be stars before the . and after the two, the stackoverflow phone app is beating me atm :-))
    – James
    Mar 25, 2015 at 6:53
  • I can list it with normal ls, but then I get .o2 (and I cannot delete it with this name)
    – rala
    Mar 25, 2015 at 15:28
  • I've created a file on my phone called '.o2 t1' and 'o2' and was able to delete both of them using ES File Explorer.
    – James
    Mar 26, 2015 at 4:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .