I have a Google Nexus 5 device. In the beginning, I was amazed at the GPS performance; most of the time I had a fix after at most 5 seconds. A few months ago I installed Cyanogenmod CM11, and as far as I can remember GPS still worked great after the flash (I registered for CM's "find my phone" service, and that worked well).

Now recently I have found that location in general doesn't work any more. I can't get a GPS fix even after waiting for a long time, and even WiFi and cell network based location don't work – I get a location, but it's off by about a kilometer, and that in a large city with plenty of WiFi hotspots and cell towers. It doesn't even recognize my home location any more, even though I have clear WiFi reception from my own router which previously was clearly associated with my street address.

I am not sure what could have triggered this problem. At some point I tried to share as little information with Google as possible (out of privacy concerns) so I configured "Location mode" to "Device only" and I also disabled and deleted location history. I guess it is possible that at some point while doing this, I accidentally "broke" location altogether, though I don't know how. In any case, after noticing that GPS doesn't work any more, I re-enabled "High accuracy" mode, but with no effect. It's also conceivable that a CM11 update caused this, but I believe that when I installed CM11 it was already at the current state M11. I never installed nightlies.

My questions are:

  • What could have broken both GPS- and WiFi/cell-based location? Is there a known issue with CM11 (M11) on hammerhead? I couldn't find anything. Is it possible that I inadvertently disabled some system service that needs to be running? Nothing under Apps / Disabled looks like its location-related.
  • What can I do to get location working again? Re-flash? Install a nightly? Hope that at some point CM11 M12 is released? Delete some system file? I'm open to any kind of idea.
  • Might I ask as to why exactly you're still on CM11?
    – blueren
    Commented Jul 17, 2016 at 17:05

2 Answers 2


Just curious if you use Google device / location manager(s)?

I have had some of theses issues come up on CM11.

Try going to Google.com then click maps as your search criteria/engine and type ' my current location ' as the search, and also in the map click the little circle in the bottom right corner (its the circle above the blue direction circle ....its the location target eye image , black and white) .....you should be asked if you would like to allow Google to access your location by now. because if not it could just be a settings thing.

I suggest using Google chrome when / if you do this.... I had better luck when I did... which makes sense since chrome is a Google entity.

I am not saying this is a fix, but I am curious about the results because this may help myself and others to get an understanding of how your devices current state due to how it handles the request(s).

CM11 hasn't treated me too well in this respect either.

  • Thanks for your answer. Yes, I only used Google services. I did some research about alternative location services, but didn't find anything easily applicable. I think the problem is not about allowing Google Maps; I have granted that access. I tested what you proposed, but using Firefox. I was asked whether to grant access to location and granted, and after that the problem was the same; location was off by about 1 km. I'll try with Chrome when I find the chance.
    – A. Donda
    Commented Mar 30, 2015 at 20:38
  • 1
    Ok well please keep me posted. I wish I could be of more assistance. Commented Apr 6, 2015 at 7:22

IT's the gapps!! I has the same problem; GPS stopped working after two CM11 updates. I reverted back to Android 4.1 but still no GPS. I renistalled cm-11-20160424-NIGHTLY-hercules (I'm becoming a pro at this by now) but still no GPS. After an idea to reinstall gapps-kk-20140606-signed after the updated....GPS started working again. I tested it with Google Maps, GPS test and My trace.. Make sure Google Services is installed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .