This morning, my Nexus 4 (Android 5.0.1) had some issues about Google apps crashing. I decided to do factory reset, so I went to Settings and apply factory reset, it was showing power turn-off, then it has not been started again. I tried to plug charger and everything but nothing is worked out.

Now, when I plug it to wall USB charger or laptop USB charger, I can't see any charging icon. I tried to hold down power + volume down buttons, but nothing happen. However, when I hold power + volume down buttons and plug it to any charger, it shows red notification light which blinks for 10 seconds. Releasing the buttons made the light go off.

Tried below solutions, but nothing worked for me till now:

  1. Put it charging more than 2 hours.
  2. Checked solutions from Red notification light on Nexus 4, won't power on, device unresponsive too, but no success.
  3. Checked this Deep Hibernate solution from here
  4. Also tried XDA developers solution

Any other possible solutions?

  • Try to take out the battery and put it back in later. Or try with someone else's Nexus 4 battery.
    – miva2
    Commented Apr 1, 2015 at 8:31
  • Tried to remove battery and put it back. It does not work. Same thing as like previous.
    – sam_k
    Commented Apr 1, 2015 at 15:07

2 Answers 2


I have the same problem once a week and have a little different solution (workaround):

  1. Unplug the phone from the charger

  2. Press and hold the volume down button plus power button for 15 seconds

  3. Plug it into the wall-charger (while still holding both buttons!) -> the red light should start to blink.

  4. After 4-5 blinks release the buttons

  5. Wait some seconds and then press the power button and it should boot

Maybe this workaround will help you.


I had luck holding the power and volume down button for 10 seconds, then plugging in the usb charger. I was presented with the technical boot screen which gave me a few options (start, recovery mode, etc) - I just selected start and it began to power on as normal. Now charging with the white icon from 0% charge.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .