After I upgraded my Nexus 5 to Lollipop 5.1, it does not automatically connect to wi-fi because Google is blocked in China and then the phone treated it as no network connection.

I have tried the solution here: How to disable captive portal detection? How to remove exclamation mark on Wi-Fi or signal icon in Lollipop?

However, it only removed the exclamation mark besides the wi-fi signal symbol, but the phone still won't connect to that wi-fi automatically.

I had the same problem with Android 5.1 upgrade on MotoX.

What worked for me - switched off WLAN > restarted the router > switched on WLAN

Hope it helps.

Settings→ Wi-Fi→ Advanced in Upper-right corner→ Keep Wi-Fi on during sleep→ Always. It'll work out.

  • That hasn't a single thing to do with captive portals. Have you read more than just the title of the question? ;) It's not about keeping the connection active (which your post would be an answer to), but about establishing it in the first place without requiring user interaction. – Izzy May 27 '15 at 11:34

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.