0

When booting into recovery mode and installing a ROM zip from my SDcard, it first says I need to mount my /sdcard (when it is mounted), and then it says "signature verification failed", despite my using a stock ROM zip.

Perhaps this has something to do with my obtaining the stock(?) ROM from a possibly untrustworthy third-party site? What is the official download site for Samsung Galaxy S4 (SGH-M919) phones?

thanks in advance for the help

(cf. my other question for more background information)

  • You probably have the stock recovery installed. It requires every zip to be signed with Samsung's signature to prevent users from flashing incompatible zips. Install a custom recovery like CWM, TWRP or Philz and try again. – GiantTree Apr 4 '15 at 12:19
  • @GiantTree: Where do I get these? thanks (and happy Easter, btw ☺). I tried this one, and it threw the "signature validation failed" error. – Geremia Apr 6 '15 at 1:29
1

I have found sammobile.com a very useful site for finding firmware for samsung devices. I don't think there is an official download site. Here is the firmware for SGH-M919

I have had the same issue before. Just trying the same process again fixed it for me.
You can try wiping your cache and dalvik cache but I am not sure if that will make a difference. Then retry flashing the ROM.
Also make sure you have downloaded the file correctly. Trying to Install a partially downloaded file will give you a lot of headaches!

0

You can get ClockWork Mod Recovery by installing it with the Rom Manager App, from GPlay or here: https://www.clockworkmod.com/rommanager

or find TWRP (my personal preference) here: http://twrp.me/Devices/

  • Your first option would not work for me because my phone does not boot up. I'll try out the second option. thanks – Geremia Apr 6 '15 at 4:08
  • …Your second option would not work because twrp.me/Devices has .img files, not .zips. – Geremia Apr 6 '15 at 4:13
  • Are you able to boot into download mode? If so, you should have no trouble installing through Odin. Follow the "Odin Install Method" here: twrp.me/devices/samsunggalaxys4tmobile.html – Jason D. Apr 6 '15 at 4:20
  • No, I cannot enter download mode, either. I can only install *.zips. Things would be very easy if I could enter USB debugging mode or download mode, but I cannot because it will not reboot. – Geremia Apr 6 '15 at 5:12
  • what to do if my tablet is not booting up. while flashing, it says that signature verification failed. – Saksham Jul 25 '15 at 7:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.