2

I can't seem to get my RCA rct6773W22 (7 Voyager) tablet to be detected via USB and RCA does not offer any driver.

If anyone has any idea how to fix this, I would greatly appreciate it.

  • I have the same tablet and have been unable to find a way for this to work. I don't see a platform listed in the question or tags - Linux, Windows, Mac? I can't get it working in Windows 10. – The Cog Jun 2 '16 at 21:32
1

This question was answered on this website. I will briefly summarize the steps I took to allow my RCA Voyager (RCT6873W42) running Marshmallow 6.0 to sync up with my Windows 7 computer and ADB in Android Studio.
1. Install the Google USB drivers.
2. Find the device ID by navigating in Windows to (Control Panel)>(Device Manager)>(Other Devices)>(Android ADB Interface)>(right-click: Properties)>(tab: Details)>(‘Property’ drop-down: Hardware Ids) which yielded
USB\VID_8087&PID_0928&REV_FFFF&MI_01
USB\VID_8087&PID_0928&MI_01
3. Open up C:\Users\Stewart\AppData\Local\Android\sdk\extras\google\usb_driver\android_winusb.inf in Notepad++ and add the following lines after both [Google.NTx86] and [Google.NTamd64]
;RCA Tablet RCT6873W42
%SingleAdbInterface% = USB_Install, USB\VID_8087&PID_0928&REV_FFFF&MI_01
%SingleAdbInterface% = USB_Install, USB\VID_8087&PID_0928&MI_01
(Notice that you have appended the the device IDs you obtained in step 2 to the direction%SingleAdbInterface%=USB_Install,.)
4. After saving android_winusb.inf, navigate back to device manager, right-click on the unknown device (Android ADB Interface) and choose ‘Update Driver Software…’.
5. Choose Browse my computer for driver software: Locate and install driver software manually. Then choose (Browse), navigating to where the drivers are stored (C:\Users\Stewart\AppData\Local\Android\sdk\extras\google\usb_driver) and clicking (Ok).
6. Make sure that the ‘Include subfolders’ option is checked and click (Next).
7. If you open up Android Studio with your device connected, it should now show up in the ADB after several seconds.
Note: Some of these details may vary. The location of your SDK will undoubtedly be different. What you write in the .inf file comment is arbitrary. I chose to write ;RCA Tablet RCT6873W42. I assume you have enabled developer options on your device, allowing USB. You should be able to easily follow Google's direction on installing their USB drivers. An additional step was listed on the website (see above) which I did not have to follow.

0

This device works with the standard Google USB Drivers. But some sources say that the driver info file has to be modified before installing.

From an XDA Topic on the RCA Voyager 7 Tablet:

Download/unzip the latest android usb drivers from google then add:

;RCA Tablet %SingleAdbInterface% = USB_Install, USB\VID_0414&PID_0C02&REV_0216&MI_01 %SingleAdbInterface% = USB_Install, USB\VID_0414&PID_0C02&MI_01

after the [Google.NTx86] and [Google.NTamd64] in android_winusb.inf file

The driver is available in the SDK Manager tool or as a standalone download.

  • This approach doesn't work for me. – The Cog Jun 2 '16 at 21:31
0

Something you may want to try, set the USB connection to use the PTP protocol rather than MTP. I did not need to modify any drivers, my RCT6773W22B was recognized as 'a camera.

Modern Android devices use the MTP or PTP protocols — you can choose which one you prefer.

To select a USB connection protocol, open the Settings app, tap Storage, tap the menu button, and tap USB computer connection. You’ll also see the protocol your device is using as a notification when it’s connected to a computer via USB.

0

I did this and it kept giving me an unable to install driver, so I selected update device driver, browse computer, then let me pick, click Google, Inc., Android ADB Interface, click next, click ok when it says may not be compatible, and then it showed up on my listed devices

0

In addition to the changes in the .inf file and enabling Developer on the RCA Voyager tablet, I had to enable USB debugging. Once you enable Developer mode. You'll see Developer Options in the Settings menu. Under Debugging you can turn on USB debugging

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.