0

I have a Nexus 5 that I am trying to update from 5.0 to 5.1 via a sideload ADB update. The OTA update within Android fails at about 30% so I am trying to do it manually.I downloaded the file but when it gets to about 50%, it fails every time. The phone says:

E:failed to verify whole-file signature E:signature verification failed Installation aborted

I was rooted but unrooted before attempting. I used rashr to flash back to the stock recovery as well. I tried flashing the stock 5.1 image in TWRP but all 3 components fail.

  • Did you modify your /system partition while you were rooted? Are you confident in the integrity of the file you're flashing? – Matthew Read Apr 4 '15 at 19:22
  • I did not knowingly modify /system. How can I check? Yes I am confident in the integrity of the file to be flashed. – William Apr 4 '15 at 20:43
  • That's actually a good question, I'm not sure how you would check without comparing to the original image. – Matthew Read Apr 4 '15 at 20:45
  • 1
    I redownloaded the updade and now I am getting an error saying /system/bin/app_process32 has unexpected contents. E:Error in /sideload/package.zip – William Apr 4 '15 at 20:50
  • Solved it. I just wiped and reinstalled the factory image. – William Apr 4 '15 at 21:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.