6

I am aware that by creating folder named Alarms, Ringtones and Notifications and placing audio files inside them will list those audio files as appropriate custom tones. However in my rooted stock Nexus 5 running Android 5.1 the alarm tones does not show the media files while it works perfectly for notification and ringtones.

Is this a bug in Android 5.1? I was able to achieve this in KitKat.

8

This worked for my 5.0:

  • Stored the files in the Alarms folder (don't think this will be necessary)
  • Go to file with ES Explorer (or other file explorer)
  • Play the file with the built in media player of ES
  • Tap on settings
  • Set as ringtone and choose Alarm
  • Go to Clock > Alarms and use your new music file as wake up alarm

Probably there is a option (just once/always) for choosing a ringtone in the Alarm menu. I think, I clicked on always by accident. (clearing cache/setting did not worked out) But this will be a pretty simple work around ;)

  • I am glad that this worked in my case as well (5.1). Interesting ways to solve an issue - that's the power of community. – Narayanan Apr 8 '15 at 3:36
  • 1
    Just wanted to chip in to say, that the audio file needs to be in the Alarms folder. – gns-ank Apr 13 '16 at 17:48
1
  1. Plug your phone into PC.
  2. Open folder → go into internal storage → alarms. File type that has worked for me is Mp3 and M4A.

I have not found any other way for this to work. If you want to stay native to the phone and not download any apps then you have to use a computer.

protected by Community Jul 29 '16 at 14:21

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.