I've a Moto-G XT1033. When I connect the phone to WiFi, it connects fine, shows the WiFi icon but uses 3G for internet. H+ or E is shown over mobile signal icon and an exclamation mark on WiFi.

Here's a screenshot:

shoes H+ when on 3G

I've to manually disable mobile data to force the phone to use WiFi. Then it works just fine.

Here's with data disabled

enter image description here

Also, this problem appeared only after I upgraded from kitkat to lollipop official ROM. Now I've switched to CM12 but the problem persists.

My WiFi uses proxy to connect to the internet and this problem is only on WiFi networks that use proxy.

Any idea what causes this or how to fix it.

up vote 4 down vote accepted

Just disable captive portal detection. In the terminal, or in adb shell, issue the command

settings put global captive_portal_detection_enabled 0

and reboot.

  • my device api is 15 and when I try this I get this error sh: settings: not found – dmSherazi Jan 3 '17 at 6:28

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.