0

Yesterday I got an Acer Liquid Z410. After installing some apps and checking out the phone, I charged my phone fully. Then I was trying to acces my phone again but it was off. So I tried to access it by turning it on, but it wouldn't start. I even tried the power button + volume up button and power button + volume down. The phone does charge and I kept it on the charger for a full night. I cant get in recovery mode. I dont have much more information except for that I cant seem to find the solution anywhere. Not the manual, nowhere.What is going wrong and what should I do? I dont know my android version but I do know I have Android.

  • If it has a removable battery: did you try taking that out for a couple of minutes, and re-insert it? If the battery is not replaceable, there's usually some "reset hole" you could stick a needle in for a few seconds to reset it, with a similar effect. – Izzy Apr 13 '15 at 15:08
  • @Izzy Yes I tried that – Loko Apr 14 '15 at 7:00
  • If it doesn't switch on at all, I'm afraid it's a case for being turned in to service. Might well be a hardware issue (e.g. broken power button or the like). – Izzy Apr 14 '15 at 9:30
  • 1
    @Izzy Yup I did that. I'm getting a new one. Thanks. – Loko Apr 14 '15 at 9:35
  • Please consider to answer your own question – especially if you get some feedback from service on what the culprit was. Might turn out helpful to others :) – Izzy Apr 14 '15 at 9:40
1

I went to the store and it had to do something with the hardware. I am getting a new phone and all is settled. Al though the store said they've never seen or hear about it happen before.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.