10

Posting and answering this to help others experiencing the same issue as me. This was also asked here.

If only one keyboard is enabled, i.e. Google Keyboard - English (US), the keyboard shown whenever text input is needed sometimes does not have a microphone icon (or any option to select voice typing).

Some things that may not show:

  • Microphone icon (in older Android versions, this was beside the space bar on the on-screen keyboard)
  • Pressing and holding space bar does not trigger the input selection screen (that normally would have featured voice typing as an option).

Please refer to my own answer below https://android.stackexchange.com/a/104896/198

9

Try installing the Google application from the Play Store.

I disabled the Google App on my phone and the voice commands were gone from the keyboard. When I re-enabled it, the microphone icon was back. Hope that helps.

  • This was my issue. When I installed this, the voice typing input method magically appeared. Thank you! – baitisj May 27 '16 at 17:42
  • 3
    This fixed it for me as well, I disabled the "Google Search" app thinking I didn't need it and lost the voice input method along with it. Was scratching my head until I figured it out. – BMB Jun 17 '16 at 18:10
3

There are two solutions that I found:

  1. Microphone icon
    • This has now been moved to the text correction area of the keyboard. Text correction may not be enabled on your device. Enable this by heading to Settings -> Language & input -> Google Keyboard -> Text correction -> Enable "Show correction suggestions." This was roughly mentioned here.
  2. Pressing and holding the space bar
    • I managed to get this option to work by enabling another keyboard in addition to the Google English (US) keyboard and Google voice typing. Like in the previous item, head over to Settings -> Language & input, then go to Current Keyboard. On the popup screen, select "Choose Keyboards" to select another input method such as Google Korean Input. You should now be able to press and hold the space bar during text input to select voice typing.

Hope this helps!

3

Additionally I found under language and input > default there is an "add keyboards" option. In my case "google voice typing" was unchecked for some reason.

  • This solution definitely works on Android 4.4.2. It is the only setting that I needed to change. – Andrew P. Oct 30 '15 at 15:48
3

While no answer provide's a straight solution, I'd like to add one.

This is for Android 5+

Go to settings > language and input > in "keyboards and input methods" submenu click on the keyboard that is active you should now be in a menu with > preferences, advanced, gesture typing options > click on preferences > you'll find a "voice input key" option just select/deselect to activate/deactivate

1

I was able to press and hold on the settings icon settins icon

and the microphone icon appeared along with settings and email icon. I tapped on it and the mic icon was back on the keyboard.

0

In Android Lollipop (I tried on 5.1.1), if you enable another language input method editor (IME, for example, Japanese IME or Hindi IME) and also have the Google voice typing enabled in the language and input settings, then when you start typing in any app where you can type, you hold down the spacebar and you will get a small menu showing you the option to voice type, then just tap the option and the voice typing input will open.

(Click image to enlarge)

IMG: https://i.imgur.com/gDjrW9q.png

0

I found it for my LG G4

Settings - General - Language & Input - Keyboard Settings - Keyboard Height & Layout - QWERTY Keyboard Layout

protected by Community Feb 11 '16 at 15:07

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.