I changed my ROM to cyangenmod 7, and I cannot install some of the applications I used to have (like skype for instance).

Here's what I got so far:

When I'm downloading it from the market it starts to download and than it disappears, and thats it.

When I am using root explorer, looking for files with the name "skype" in them I find a skype classes.dex file in sd-ext/dalvik-cache/.

So here are the questions:

  1. Does anyone know this problem and has any idea how to fix it?
  2. I'm thinking that deleting the dalvik-cache will fix it, but I'm not sure, and I don't know what it means (its consequences on the device and other apps).

Thanks a lot for your help! :-)

  • Deleting the cache shouldn't do anything. The only thing I can think of is that CM doesn't have your proper device string, so the Market thinks you don't have a phone supported by Skype. Commented Jun 16, 2011 at 20:13
  • Thanks :-) But how do I check my device ID?
    – TCS
    Commented Jun 16, 2011 at 21:26
  • 2
    I'm not sure if there's an app to easily edit/view it, but it's in the build.prop file. See android.stackexchange.com/questions/5078/… Commented Jun 16, 2011 at 22:27

2 Answers 2


Fixed it.

I'm writing my fix if other people will encounter the same problem. Also, that I must stress that this fix will work only for Cyangenmod users!

The problem is that there is not enough space in /cache/, so when the market wants to download a "too large app", it throws an exception saying "there is not enough free space". You can see that error if you have the android SDK and you run "adb logcat", and try to download an app (you will get "not enough free space in internal download storage").

So how to fix it? The easiest way I found is to download an app called "S2E". You can try to download it from the market. If you can't, look for the APK, and install it from the SDCard.

Once you installed it, you can choose directories that will be moved to the sd-ext instead of the phone's internal memory. Check "Download cache Location: /sd-ext/download". Than click on "menu" and than "Reboot".

That is it! :-)

  • +1. Many thanks for that ! S2E didn't worked for me, but I figured out another "simpler" way to make it work, thanks to your answer. (See my answer below)
    – ereOn
    Commented Jun 25, 2011 at 10:06

Thanks to @strDisplayName, I figured out how to make it work:

If S2E doesn't work for you either, you can launch an adb shell and type the following commands:

# cd /cache
# mv download download.old
# mkdir -p /sdcard/cache/download
# ln -s /sdcard/cache/download download

And it should just work :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .