7

I just installed Cyanogenmod. It's my understanding Cyanogenmod is a ROM so I was bit suprised when my TWRP custom recovery was replaced by Cyanogenmod's own recovery. Why is this?

Cyanogenmod's recovery can't do anything; it has no backup or restore options and each time I try to apply an update it says-

signature verification failed.

  1. Is it possible to get back to CWM or TWRP or somehow get Cyanogenmod's recovery to work?

I can't flash a new custom recovery from the phone since Cyanogenmod's recovery fails at flashing, and I tried using fastboot from the computer and it appears to flash TWRP but then it just goes by to Cyanogenmod's recovery.

  1. I once read that TWRP/CWM only work with stock kernel and Cyanogenmod has it's own kernel so they won't work. Is this true?

I don't think it's relevant to the question but my phone is Xperia Z2 D6503 and the CM is 12 (Lollipop)

  • I have no idea about the answer to this, but, could you specify your device model and number? After all, you should know to do so, I mean, look at your reputation. Come on. By the way, CyanogenMod doesn't come with its own recovery. I have installed official builds of various devices, and it has shown no such replacement of the sort. – rjt.rockx Apr 10 '15 at 12:30
  • @rjt.rockx hmm device model/number are irrelevant. You don't understand the question. It's do they make custom recoveries so they need a specific kernel? and does Cyanogenmod count as a custom kernel (it has mod in it's name, people call it a ROM, so I don't know). You clearly don't know what your talking about as cyanogenmod does come with it's own recovery and that's the whole point of the question. You say you have never used it so why would you know? – Celeritas Apr 10 '15 at 21:48
  • 2
    @Celeritas :- There is this option in Developer Option menu that I must mention. While I do not understand the reason for such, in Cyanogenmod's Developer Menu, you might find an option like Update CM Recovery. As long as it remained checked, no matter how hard I tried I couldn't replace my recovery through fastboot. Fastboot showed me no error but rebooting the phone to recovery didn't booted into new one. I unchecked and it worked. – Firelord Apr 10 '15 at 22:03
  • @Celeritas :- There is another thing that I never understood. I've OnePlus One and the first time when I tried to replace the recovery with fastboot, it didn't worked. No error in fastboot command but didn't booted into new one too. All I had to do was factory reset and after that it worked. I know it makes no sense that how could or why should be it working out this way but I thought I should convey my point here. – Firelord Apr 10 '15 at 22:05
  • 1
    @Celeritas:- However, you didn't mention that whether you tried flashing TWRP/CWM recovery from inside the Android like through Flashr app. – Firelord Apr 10 '15 at 22:07
3

From xda thread: CyanogenMod recovery is basic, so you have to flash another one. The easiest way is to use rashr app and it worked for me perfectly

  • I tried this without success on Android 5.1. It said flashing is done, but it starts the Cyanogen Recovery after that again. Fashify (play.google.com/store/apps/…) worked for me, though. – modiX Aug 5 '15 at 11:47
2

In case you are having this problem with a galaxy s2 and cyanogenmod 12.1, then the solution is to flash the original developers alternative stock kernel with TWRP installed. It is signed and thus can be flashed with the cyanogenmod recovery.

For details and further links see my answer on this question: How can I backup and restore Cyanogenmod 12.1 rom installed on my Samsung Galaxy 2 i9100?

1

Especially for Galaxy S2. I stuck with Cyanogen Recovery for a couple of days. Neither Rashr nor Flashify worked for me. In the end, reflashing a TWRP kernel (Apollo 9 light) with Flash Gordon did the trick.

  • for Galaxy S2 I9100, recovery image with IsoRec support (like recent TWRP 3.0.2+) will allow you to keep using TWRP instead of CM Recovery - see twrp.me/devices/samsunggalaxys2i9100.html. You need recent CM too (like cm-12.1-20160203-NIGHTLY-i9100.zip; cm-12.1-20151116-SNAPSHOT-YOG7DAO1JN-i9100.zip won't work as it lacks IsoRec support) – Matija Nalis Apr 29 '16 at 3:41

protected by Community Feb 14 '16 at 21:09

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.