1

My problem is that my device is not updating apps when I hit the auto-update button, it does only update all apps if the screen is on all the time! how do I make them update when the screen is off ? I mean is that new in the higher version of play store, what is that functionality? Is this just me or all the other devices that have an updated version of playstore? Please help!

  • Simple case - when your screen sleeps, does your network connection, too? Does your Wifi disconnect during sleep? – wbogacz Apr 10 '15 at 17:59
  • No it does not ! this happens on all devices that I have, not just this one – Karimimo Apr 10 '15 at 18:01
  • Power Saving Mode, or some battery savers, maybe? BTW - My tablet has an advanced Wifi setting - "Keep Wif-Fi on during sleep"; you may have to search for it. Mine is in Wifi\Advanced, and I have it enabled. – wbogacz Apr 10 '15 at 18:41
  • Still the same, thx btw :) – Karimimo Apr 10 '15 at 18:43
  • One last guess - Do you have an automation app, like Tasker, or Llama, running that engages something like a "sleep" profile, which turns things off? Then a "wake" profile to return them in the morning? – wbogacz Apr 10 '15 at 18:46
0

Go to the settings option in the play store and switch on the Auto-update apps over Wi-Fi only. :)

  • How does this address the screen sleep issue? Especially when Wi-Fi sleeping seems to be the cause? – Matthew Read Apr 12 '15 at 15:30
  • He will have to disable background data restriction, maybe. – Ajith Kumar May 3 '15 at 11:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.