0

I have tried to root my Moto G, which had the bootloader unlocked, and was on 5.1 GPE to install CM 11.

I have had a lot of issues...

First I successfully installed the CWM recovery, when I went into it it was flickering for some reason. After a reboot the recovery was even gone.

Installed it again, booted into android, put the CM file into storage, went back into recovery, installed it from there. I did not do a format first because it would have deleted the cm file as well...

cm-11-20140504-SNAPSHOT-M6-falcon

So CM installed, upon boot, the cyan logo was flickering, then it was encryption unsuccessful and had to restart, after many restarts it was the same...

Now I have not access to the storage so I cannot even put on another ROM, and the installed ROMdoes not start. No idea what to do.

I tried some other recoveries (as that's all I can do at the moment) all of them flicker.

  • twrp-2.6.3.1-MotoG4.4.img
  • philz_touch_6.58.7-falcon.img
  • cwm-6.0.4.7-MotoG-GPE-4.4.img
  • clockworkmodrecovery.6051.falcon.img

Any help appreciated.

  • if you found a solution, please post it as an answer, so that other users will be able to find it and vote on it (the text of your original solution is available here). You can also mark the answer as "accepted" so that others will see your question has received a satisfactory answer. – eldarerathis Apr 20 '15 at 15:58
1

As Moto g received the Lollipop update recently, other roms should adopt the changes.

If you want a working phone you can flash the stock firmware or you can sideload a custom rom but this requires a computer and fastboot files installed.

I encountered this problem and solved this as follows:

If you have installed fastboot files on computer and a custom recovery on your device(Twrp is my choice) then download any custom rom which you have tried before(just to confirm that it should work as you have already it) and place it in fastboot folder.

Reboot the device to recovery and you have a option to sideload the rom from computer click on it. Connect the device to computer and and type the command "adb sidelead yourrom.zip" it may take about 5 minutes to complete. Once rom is sideloaded it flashes fine.Do a factory reset and reboot.

Go to this link if you want info about custom roms.

Happy flashing

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.