4

An update fixed my problem. It was - as I suspected - just a bug.

Recently I upgrade my Samsung s4, and now every time when I get a message via SMS, the text - and background - all white?:

(Click image to enlarge)
IMG: sample

I tried messing with the settings, but still my messages won't show up?

How can I read my SMS messages again?

Phone Info

  • Samsung S4(GT-I9505)
  • Android version 5.0.1.
  • Backup your data and then restore factory settings may help. Also install any other launcher may help – Faizan Akram Dar Apr 14 '15 at 13:25
  • If you don't want to do that, switch to another messaging app, like Hangouts? Atleast then you can get your messages while you figure out what the problem is with the Messaging app... (also, have you tried closing and clearing the cache of Messaging, not sure if that will help though) – Mike Apr 14 '15 at 20:42
  • @Mike how do I clear the cache of messagin? – blade19899 Apr 14 '15 at 20:57
  • Apparently, the answer to this, is Update your Samsung device – blade19899 Dec 24 '15 at 8:29
  • 1
    If your problem is solved, please post an answer and then "accept" it with the green tick mark. That way, it won't show up as unanswered for other visitors any more. – Dan Hulme Jun 13 '16 at 8:55
0

Try a third party messaging app, such as Google Messenger or Handcent SMS to see if the problem is duplicated. If so, verify you're running the most current software version with Samsung Kies. If you are, try a factory reset and see if that works. There's a possibility that the Lollipop update for the S4 has some bugs that will hopefully be patched rather quickly.

0

I used Hangouts to get around this problem, however last night my phone downloaded a software update that has corrected the Messages app, updated Contacts with FB photos and re-linked my phone to the FB photo albums - hoorah! Oh how I've missed Swype when sending out text messages :-)

0

Actually we can't read sms in lollipop without approved permission in run time,first check permission in run time then you access sms.

-1

I just figured it out.. I turned off my phone for 20 seconds and my phone messages showed up. If you keep your phone on all the time like I do, then turn it off and back on, your messages should return.

-2

Phone could be in Guest Mode. Go to settings...security...then deactivate guest mode.

  • That wasn't it. The questioner already updated their question to say it was fixed by a software update. – Dan Hulme Jun 13 '16 at 8:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.