4

I am having an issue with Mobile data no longer working. Mobile data WAS working the day after updating to Android 5.1 on my Nexus 5. But now (1 day later) it is not connecting to Mobile data. It just has the cellular icon, with an exclamation point. I've tried toggling data, airplane mode, wifi, rebooting, factory reset, and reseating the sim card. I've even tried hopping on one leg while chanting this new update blows!!! The last thing I tried is to call my carrier and go through 2 hours of troubleshooting. They said the only thing left for them to do is send me a new sim card. It makes no sense. Everything else works fine. I can make and receive calls. Texting works. And Wifi works as well. Just not the mobile data. The weird thing is that it stopped working on the first day of my mobile data cycle. But the carrier swears that all is well on their side. Someone, please rescue me!!!

  • 3
    +1 for "I've even tried hopping on one leg, while chanting this new update blows!!!", that got me. In all seriousness though, have you double-checked whether your APN settings are valid and unchanged? – aureljared Apr 16 '15 at 4:03
0
  • Try a different sim card.
  • Check if the APN settings are right.
  • Check for a bug fix OTA update.

If the steps above didn't help please leave a comment.

0

I've had a similar experience: I need to select settings, then under 'Wireless & networks' hit the 'More' option, then select Mobile Networks, then enable Data Roaming, and then switch it off again. And bang, my mobile data works again. Somewhat similar to hopping on one leg and chanting.

The problem that remains is that every time I walk out of range of a WiFi network my phone is connected to, I loose mobile data and have to do this routine again. It's getting a little tiring :(

0

Mine won't connect to mobile data when I toggle it on, but if I leave it toggled on and reboot, it connects on reboot.

0

After the 5.1 upgrade in my phone it wouldn't connect to my home wifi. I tried several of the fixes on this site and none worked. When I tried to connect it would ask for my password but when I put my password in the connect was still greyed out. After more than a few tries, the light dawned. It didn't want my Century Link password, it wanted the key passphrase on the bottom of the wifi router. That worked. I hope this works for you.

Johnny Blaha

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.