2

I have an 802.11ac router at home with both 2.4Ghz and 5Ghz connections and separate SSIDs for each. In most parts of my home, the 5Ghz connection is utterly useless, which I learned the hard way from my phone regularly connecting to it and then failing to do anything while it does. So, of course, I told my phone to "forget" the connection.

But since Google backs up all my WiFi networks and syncs them with all my devices, which is a great feature, it constantly restores this WiFi network to my Nexus 6 (and did the same to my 5 before that) without my realizing it until I notice my phone being useless at home again and find that it's reconnected to it. I'll forget it again, it's fine for a while, and then after an unknown period of time it's back.

Anyone know how to PERMANENTLY forget this network from my Google account?

  • How about renaming the SSID of your 5Ghz band? – user128825 Sep 24 '15 at 8:59
3

I experienced the same behavior, and through quite a bit of trial and error, I have a pretty solid theory on why this happens.

I think as a "convenience", Android looks for 5GHz networks sharing the same root SSID as a 2.4GHz network and assumes that the password is the same. So for instance, if you have MyNetwork and MyNetwork (5GHz), you can connect to MyNetwork and Android will automatically try the same credentials on MyNetwork (5GHz).

There's nothing I've found on the Android side that will prevent this. The only thing you can do is to change the SSID of the 5GHz network so that it's completely different from the 2.4GHz SSID.

  • That sounds entirely plausible given my experience with it. Since this time I've changed my configuration entirely, due to an upgrade on the router I used, so I can't directly test this in my environment. But as I've ended up in scenarios where I hadn't programmed the 5G and yet my phone connected to it, this seems likely. I originally assumed the router was passing the info along via a protocol I was somehow unaware of. – TurboFool Dec 21 '15 at 20:36
0

This is an old question, but I had the same issue driving me mad, so in case you did not find a solution, this is worth trying.

I do not have a solution to permanently forget the network, but you can disable 5GHz on your phone, if you never need it. Go to settings, wifi, advanced and find the WI-Fi frequency band. On my HTC phone, I can select 2,4 GHz only.

This solved my problem.

  • 1
    Hello! Unfortunately that's not really a solution, so much as a workaround. There are environments in which 5GHz works well, and I'd like to maintain access to it. I just need to forget this one network that I know is a problem for all my devices. – TurboFool Jul 28 '15 at 23:55
0

I do not know a firm solution but I would suggest trying the following.

Follow the information in this to turn off Wi-Fi sync on all your devices.

Sync saved Wi-Fi networks to your Google Account

You can have your saved Wi-Fi networks and passwords sync across any Android device where you're signed in to your Google Account. This lets you connect automatically to your saved Wi-Fi networks on any device signed in to that account.

  1. On your mobile device, open the Google Settings app.
  2. Touch Networking.
  3. Move the switch next to "Sync saved Wi-Fi networks" to On.
  4. If you're signed in to more than one Google Account on your device, choose the account you want to sync.

Any changes that you make to your saved Wi-Fi networks — like adding or removing networks or changing passwords — will be saved on other Android devices signed in to that account. To turn this feature off, simply move the switch to Off.

Manually delete the offending network from all devices. Turn on Wi-Fi sync and see if it syncs correctly.

There are two outcomes to this:

  1. It re-syncs and realises you're missing the offending network, then adds the offending network to all phones/devices.
  2. It re-syncs and realises the synced/cloud copy of the Wi-Fi networks it has is out of date and "updates" by deleting the offending network from the sync networks.

Unfortunately I do not know the ins and outs of the Google Sync system but it is worth a shot.

  • Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. Otherwise, your answer becomes useless in case the link dies. For further hints, please see: How do I write a good answer. – bmdixon Sep 25 '15 at 14:38
0

Unrelated to a 5Ghz issue, I could not forget a network on my phone from a user other than the owner. Once I switched to Owner, changes to the WiFi settings were permanent.

  • This was the right solution in my case – TMG Aug 15 at 12:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.