0

I have had my Samsung Galaxy S5 for about a year now and it has been working fine until a few days ago. I would use my wi-fi when I have access to it and then I would switch to my 4GLTE when I don't have access to any wi-fi. This has been working for the longest and I only had to switch to 4GLTE when I'm at working or driving. But recently, my phone would not switch back to 4GLTE when I lose wi-fi connection or even turn off the wi-fi option on my phone. Restarting the phone would temporarily fix the issue but I was wondering if there is anything else that I can do?

I got the phone from T-Mobile but I been using MetroPCS ($60 unlimited data plan) since about 2 months after using T-Mobile.

5
  • This sounds like a network issue. Have you tried a different phone to see if it has the same trouble connecting? Commented Apr 17, 2015 at 20:02
  • I don't really have another phone to test with. I guess when my friend comes over I'm going to hijack his phone and test it xD. I can say though that I never shut down the phone and I only plug it in for charging when it reaches 10% battery if that helps any.
    – John Odom
    Commented Apr 17, 2015 at 20:03
  • @MatthewRead It appears that this issue does not happen on my friend's phone who also has the same phone plan but a different phone (an LG phone). I'm guessing it is an issue with my phone's network hardware?
    – John Odom
    Commented Apr 28, 2015 at 21:39
  • 1
    Hmm, given that it does work sometimes I would suspect a software problem rather than hardware. I'm not sure what to suggest other than a factory reset. Commented Apr 28, 2015 at 21:43
  • 1
    I'm guessing it is an issue with my phone's network hardware? -- Upgrading the Modem (software) sometimes does help. It did at least on my device.
    – Firelord
    Commented Apr 29, 2015 at 2:11

2 Answers 2

1

I suffer from the same issue. I have discovered the following to work for me.

To prevent it occurring: Turning off WiFi Calling seems to work (It's the last item under "Settings >> Call"), if you have it available and on. I've not had to to resort to flight mode (see below) since disabling this.

Countermeasure when it occurs: Putting the phone into Flight mode and back out of Flight mode will restore the ability to connect to 4G, at least until the next time it fails after coming off WiFi.

Hopefully the above will help you avoid rebots.

1
  • It is incredibly frustrating, but this seems to be a good solution for me without having to restart the phone. Maybe it means it is time to buy a new phone xD. Thanks for the workaround!
    – John Odom
    Commented May 7, 2015 at 16:01
1

I am having the same problem with my Sony Xperia z3v (verizon). I also recommend turning off your mobile data connection and turning it back on. it should be in the settings under mobile network settings. After I did that I was able to turn off my wifi and it automatically switched back to 4g connection.

1
  • I tried this solution before and it worked a few times, but the 1 solution that has been working 100% so far is re-scanning for mobile networks.
    – John Odom
    Commented Dec 14, 2015 at 15:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .