0

So I wiped my phone because I was going to install Cyanogenmod 12 (Nexus 5) but now it is wiped I can't make any folders or move any ROMs onto the phone through MTP even though it shows in Windows.

How can I fix this?

4

I had the same issue with MTP not working from TWRP (Windows 10 x64). I used adb push as a workaround way to put update on the phone after disabling MTP from TWRP "Mount" menu:

adb.exe push update.zip /sdcard
adb push open_gapps-arm64-7.1-nano-20170625.zip /sdcard
1

Switch off your device. Take out your memory card. Place it in some card reader. Access it on your computer and place the ROM in it. Now, place the memory card back to your device and go to recovery. Flash the ROM from memory card and you are good to go... :)

0

I am presuming that your device doesnot support SD-card (memory-card). You can see MTP, it means that drivers are fine.

  1. Update your TWRP TWRP for LG Nexus 5

  2. Update your drivers and reboot PC.

  3. Format Data from Wipe option in TWRP.

  4. Connect to PC, and hope you can see MTP. Copy CM12 (for your device ONLY) ROM from PC to internal storage. Don't forget Gapps and Supersu zip files too.

  5. Flash ROM first, then gapps and finally Supersu.

  6. Reboot phone, Done.

If above steps doesnot work, then last thing you can do, is to go to bootloader and flash ROM using sideload.

1
  • I ended up using ADB to install CM12. Thanks for the help anyway!
    – cheese5505
    Apr 22 '15 at 4:38
-1

If any of u suffering from this problem then the best way is flash the older version of twrp....i stucked in the same situation my phone doesn't support sd card and mtp not working as well.......actually i was using stock firmware in my Gionee S5.1 i tried to reset it as usual but my phone stucked in bootloop means my os was totally gone but luckily my twrp stills there hence i connected my phone to the pc its connected via mtp at that time, i found that there is a new version of twrp available i flashed it and mtp stops working as i was wiped out my whole internal memory data and my phone doesn't sd card so i downloaded the previous version twrp puted it in the usb and connected with otg and flashed and mtp worked again and then flashed new rom!!!!! I hope it will help

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.