1

So Google Play randomly stopped working. I can see my games achievements and so forth, but loading the game loads me as a new user completely and I have tried on 9 devices all with the same issue.

  • OH I should add that this is for all games on all devices that use it. No changes were made to devices or accounts. One day it worked the next day in the morning it didn't. – lost everything Apr 21 '15 at 2:23
  • Does it happen with one game (in this case it sould be a problem in the game) or with all games? – Ale Apr 21 '15 at 14:35
  • HI Ale. it happens with all games, things like CSR racing(all versions), Marvel Puzzle Quest) and so forth. I can see the achievements on my webpage for googleplay but all the games refuse to see that I have older working savegames. – lost everything Apr 22 '15 at 3:52
  • Are you able to log out, then log back in to your Google account in the game? – 1990clb Apr 24 '15 at 8:54
  • AFAIK, game saves (usually Google+ or other platform) are not tied to achievements (Google Play Games). – Andrew T. Apr 27 '15 at 5:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.