4

Whenever I plug in the charger into my HTC Desire (2.2) it unmounts the SD card. I can get around it when it's connected to a PC or other device via USB by selecting Charge Only again in the charge menu - it then re-mounts the SD card. However, you do not get the charge/connect as options when it's a wall charger so I cannot get around the problem (therefore losing all my apps installed on the card, music etc while it's charging).

Has anyone seen a bug (feature?) like this? I've been trying to find anything about this problem online but to no avail...

Thanks in advance!

  • Can you provide logcat output when connecting your wall charger? Somewhere in pastebin. Last relevant lines only. wiki.cyanogenmod.com/wiki/Logcat – Denis Nikolaenko Aug 4 '11 at 4:22
  • @Denis you'll have to explain what this is all about... – Dmitry Selitskiy Aug 4 '11 at 6:39
  • @Dmitry: Is it the original HTC charger or a third party one? – Robert Dec 2 '11 at 8:45
1

Strange. I have an HT Desire running 2.2 and don't have that problem. It might be the cable of the charger that is incorrectly registering as being a USB connection (faulty, cheap knockoff that is incorrectly wired?) Try another charger. Blackberrys also use micro USB so ask a buddy to use their charger

  • It happens with several chargers I tried. Most of the time I use the one from my Plantronics bluetooth headset – Dmitry Selitskiy Jun 19 '11 at 22:17
0

Interesting, never had that happen to me. If you can, try what pufferfish suggested - recharge with a different charger/cable (maybe ask around at work?)

Or if that isn't convenient possibly try taking out the SD-card and putting it back in? I've had my SD-card randomly unmount itself once and re-inserting it seemed to have fixed it.

  • I have removed the card on a number of occasions and that did not help... Thanks for suggestion! – Dmitry Selitskiy Jun 19 '11 at 22:17
  • hm, odd... another stab in the dark. Turn phone off, plug in to charge. Turn phone back on... does the SD card still get unmounted? – pyko Jun 19 '11 at 23:40
  • I will try that when I get to the charger, thanks. – Dmitry Selitskiy Jun 20 '11 at 0:18
  • Sorry, forgot to answer here - did not help – Dmitry Selitskiy Jul 4 '11 at 22:40
0

Your HTC Desire is definitely has a malfunction. Try to reboot. As a workaround, you can try to configure to do nothing if USB cable is connected. Search for option in Menu => Settings or from notification when connected to PC.

  • It happens when a wall charger is connected, not just a USB (i.e. when phone understands it's a USB connection and gives you options about what type of connection to establish) – Dmitry Selitskiy Aug 3 '11 at 5:57
  • You said "I can get around it when it's connected to a PC or other device via USB by selecting Charge Only again in the charge menu - it then re-mounts the SD card.". I believe that you have USB disk configured as default when connecting USB cable. Try and see if this settings applies when you connect your wall charger. I may apply (incorrectly) in your case, because the phone detects the charger as a USB device. Just configure "Charge only" to be the default. – Denis Nikolaenko Aug 3 '11 at 20:31
  • Default connection type is already "Charge Only" – Dmitry Selitskiy Aug 3 '11 at 21:45
0

Try another SD card? Maybe the problem is voltage stability...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.