4

Cellular data stopped working immediately after "upgrading" to 5.1-lollipop OTA (from 5.0.2) on my Nexus-4. I am seeing the exclamation point in the signal strength indicator at all times, except when Wifi is on and connected. Voice calls work fine. Wifi works fine. 2 hours on the phone with Simple Mobile, then 2 hours back and forth with Google support, and still no resolution. So far I have tried:

  • Erase and reprogram APN settings
  • Remove and reinstall existing SIM card (that was Simple Mobile's suggestion, although I think if voice is working SIM is probably OK. I don't have a spare to try right now.)
  • Turning phone off and on
  • Reboot in Safe Mode
  • Turning Cellular Data switch off and on
  • Turning Airplane mode off and on

The exclamation point on the cellular strength icon seems to follow the exclamation point on the Wifi icon, i.e., both go on and off at the same time--when a Wifi connection is made or broken. Is it possible that this may be a bug related to an accidentally shared variable between the two?

Google 2nd level support has said they don't have an answer. They want me to try a new SIM card, which I'm trying to get from Simple Mobile. If that doesn't work they want to "discuss repair options for the phone."

I've seen some other people with similar problems but haven't seen any fixes or workarounds other than what I've already tried. Does anyone have any ideas?

  • Ideas about "what to try": 1) go into a shop or to a friend asking for an alternative SIM to try with. 2) check the logs for hints (e.g. adb logcat; see our ADB tag-wiki and logging tag-wiki). 3) try your SIM in another device (to check whether it's the SIMs fault). 4) ask your mobile provider if they can see "something strange" on their end (would be a real coincidence, but they might have "switched" something around/off). – Izzy Apr 22 '15 at 11:18
  • I just rebooted my LG3 again, and now the 4G data works again. I suggest another reboot. – Malachi Apr 22 '15 at 21:36
1

I'm back up and running. Here's what I know at this point. I'm posting it here because I think many people may experience the same behavior.

After much back and forth with Simple Mobile (note that they share some infrastructure with T-Mobile, Tracfone, etc., so users of those services may be affected as well) they found that my cellular data had been disabled on their end. Nothing was wrong with my account, indeed, voice continued to work normally, it was just the data that had been disconnected.

I asked why this happened and the 2nd-level support person told me that they are still investigating but one thing that's possible is that a change in 5.1 Lollipop caused something to fail on their end. She said they have been receiving numerous trouble calls with the same symptoms, all with phones recently upgraded to 5.1.

So, allowing for the typical misinformation that we all get from customer support, this actually seems like it's plausible. I don't want to spread misinformation, but if anyone else is tearing out their hair with these symptoms, try leaning hard on your carrier to check your line.

0

Toggling between 2G and 3G fixes the problem for me.

I just updated to Android 5.1 on the Nexus 4 and am also experiencing this problem. It's pretty poor of Google to release such an update with such a big bug.

Every time I restart my phone cellular data will NOT connect unless I toggle between 2G and then back to 3G.

0

That's indeed strange! I'm based in Australia on the Telstra network and was suffering the same symptoms as you after the update.

As above, by toggling my data between 2G and 3G a few times and restarting my phone it's now come good and even restarting the phone data connects automatically without issue.

I wonder if the 5.1 update on the Nexus 4 does indeed affect the carrier somehow of the CSR just blamed it on that. I've learned over the years to not bet the house on what CSR say unfortunately as their information is incorrect most of the time.

Cheers

0

I have the same issue on my LG G3. I updated to CyanogenMod 12.1 (Android 5.1.1) and mobile data goes out on boot and several times a day. To fix this, I turn airplane mode on and off and it reconnects to Verizon's LTE network.

protected by Community Apr 28 '15 at 12:59

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.