0

Today I was installing custom ROM on my xperia C. After installation completes, I reboot the phone. Now, it is not starting. I tried pressing keys(power, vol up, vol down) with different different combinations but nothing happens.

The only response I am getting is either connecting to charge or connecting via usb cable to PC and that response is it is just showing RED light as notification only. It isn't getting boot in FLASH mode so that I can Flash it with new firmware.

The reason I concluded for this is that the ROM I installed wasn't for Xperia C.


Here's what I did that led to the current situation:

  1. Copied a ROM of another device (I think it was of Micromax a116) on to my sd card. link to that rom
  2. Rebooted my phone in and wiped all cache, partitions and data with cache.
  3. Installed zip from sd card.
  4. After successfull installation, again clean the dalvik cache.
  5. Rebooted phone.

There it popped up an option I do not clearly remember, something like "flash recovery mode not installed (yes/no)". I just slide for back option and screen blanked out. After that nothing happens. Only RED Light after connecting USB.

Anybody help me!!

  • With some luck, it's just "nothing displayed", while something is still done. Does it show up on your computer when connected? I'd try the key combo to boot into recovery (keep it pressed for 20..30s to give it some time), then connect via USB and try adb devices. With some luck, the device is detected – and if so, we can give further advice. If not, try the key combo for Fastboot mode and fastboot devices; bootloader is even "simpler" and usually not replaced by ROM flashing. – Izzy Apr 23 '15 at 9:17
  • No, it wasn't connected to computer at that time. Now, whenever I connect it with PC via USB cable in Windows 7, a notification tone beeps up in PC as it is trying to install drivers like something, but after 3-4 seconds, it again beeps for disconnection/failure installation. The RED light continuous and it blinks when that disconnect sound buzzes... And nothing else is happening in it. – Choxx Apr 23 '15 at 9:36
  • @Izzy I tried pressing all possible keys combination to boot it in any mode(flash/recovery) but no response at all.. – Choxx Apr 23 '15 at 9:41
  • There are often device-specific solutions (I know that from a tab I'd bricked a while ago, where the screen stayed blank as well). Not having any Sony device, I cannot help any further – but someone else might be more familiar with your specific device to help you out. Good luck! – Izzy Apr 23 '15 at 10:27
  • @choxx you can try flashing the ftf file with flashtool tutorial : forum.xda-developers.com/showthread.php?t=2054486 – samnaction Apr 24 '15 at 14:27

Browse other questions tagged or ask your own question.