3

A few days ago, my phone suddenly started giving me constant "google play services has stopped" pop-ups.

Auto-updated Google Play Services version: 7.3.29 (1866531-036)(7329036)

I tried force quitting, uninstalling, and reinstalling the older version (3.2.25 (761454-36)) along with reinstalling play store app. This made the error pop-ups stop, however, when I tried updating the Google Play Services, it said that google no longer supports your hardware (or something like that). When I tried again, it did update it through play store, then started giving me the constant "google play services has stopped" error again.

I am suspecting that the recent Google Play Services is not supporting Amazon Fire Phone (Fire OS 3.6.8 (128003620)). Is this indeed the case?

Does anybody have an older version of the Google Play Services that work?

Screen captured the message:

enter image description here

6

This seems to be due to a bug in the current version of Google Play Services, and it's not just limited to Fire Phones. There's a discussion about it over at XDA Developers, which I'd recommend keeping an eye on.

For now there doesn't seem to be a good solution yet other than uninstalling Google Play Services and reloading an older version - and even then rebooting the phone will automatically update Google Play Services to the broken version. I've seen some commenters say that uninstalling the Play Store will keep Play Services from updating, but I haven't tried that yet.

2

Look for an update for the fire phone out of Germany or UK. Download it to sd card, turn off WiFi and have phone search for update. Everything works like play services and even backgrounds now work. Still no Android wear though.

1

I also installed the older 7.0.99 036 version. All is well still and it has now been a few hours of using the phone normally. I am even running Google Maps with no errors or Play Services stopped notification. Try uninstalling the four Apks, then reinstall in the correct order with 7.0.99 Play Services instead. Then force quit Google play services in the manage applications menu. Go to Google play and login with your Gmail credentials. This will restart Google play services, but without triggering the play services stopped error. Cheers.

  • I have been doing this myself but it keeps updating itself after a reboot. – trpt4him Apr 25 '15 at 22:52
0

I downgraded to Google Play services 7.0.99 (1809214-036). It still gives me a warning, but doesn't constantly crash.

  • 1
    That isn't the case. Sometimes FCs (Force Close) happen. Just get a newer or older version from APKmirror. – rjt.rockx Apr 23 '15 at 5:07
  • No matter what I do, Play Services automatically updates to the newest version. Do you know how to prevent it? – FMFF Apr 24 '15 at 2:22
  • @FMFF Don't reboot your phone. If you do, it'll update... – Memming Apr 24 '15 at 2:35
  • 1
    @Memming didn't restart, all autoupdates are disabled, yet this damn thing keeps updating itself. – FMFF Apr 24 '15 at 2:46
  • @FMFF I also noticed that whenever Google play store runs, it automatically updates. Very annoying! – Memming Apr 29 '15 at 20:19
0

Go ahead and uninstall google play services.. your google apps will not work but the play store and all other thirdparty apps work just fine.

  • Thanks! But the google apps always request installing google play services.. – Randel Apr 25 '15 at 20:07
  • Play Store doesn't work without Play Services, not at least on my devices! – Firelord May 3 '15 at 7:51
0

After upgrading to Fire OS 4.6.1 (461013820) OTA, the problem no longer persists.

protected by Community Apr 25 '15 at 13:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.