2

My phone plan comes standard with a lot of data and as a result, I've been regularly using the Mobile Hotspot feature built into it, on my laptop. The phone is a Samsung Galaxy S5 and is rooted on a stock TouchWiz KitKat 4.4.2 ROM. This has worked very well since I got the phone, and I haven't had any issues till the other day. As usual, I ran out of credit so I recharged. I tested out the data and 4G seemed to be working, but when I attempted to connect my laptop to the WiFi hotspot, it didn't work.

I checked on my laptop and it reported not recieving an IP address from the phone. Surely enough, no other of my devices would connect to it either, and the phone stated that nothing was connected. I tried everything except resetting the phone (lots of root data which is difficult to back up/restore). I attempted to renew the DHCP several times, I restarted, I verified that mobile data was enabled and the APN settings were correct, I restarted all devices several times, I cleared the phone's cache and I verified that the correct necessary hotspot, DNS and DHCP daemons and services were running on the phone. In addition, I verified that these services were running under the correct permissions.

I also had a look through the Android system log and although there weren't too many errors or warnings, the only interesting things there were

I/dnsmasq (19328): failed to send_ra: face_enumerate,parm.found_context

I/dnsmasq (19328): failed to update ra:send_ra

W/ContextImpl(903): Calling a method in the system process without a qualified user

Later:

I/hostapd(19314): AP-STA-CONNECTED (client MAC address)

I/hostapd(19314): AP-STA-DISCONNECTED (client MAC address)

These two lines loop indefinitely.

There don't appear to be any other errors - just connection and disconnection notices. I have also tried completely removing all WiFi and hotspot settings, caches and CFG files on the phone. Despite this, it didn't seem to make a difference. Although DHCP issues are unlikely to be caused by internet availability, just to be sure I have confirmed with my carrier that there are no new hotspot or tethering policies introduced. Mobile data works fine on my phone and USB tethering to any device works normally, but WiFi tethering doesn't.

I can't for the life of me figure out how or why this is happening. I haven't installed any system or root apps recently and haven't updated anything in the last few months.

Is there anything else I can try?

migrated from superuser.com Apr 23 '15 at 15:13

This question came from our site for computer enthusiasts and power users.

  • Have you tried a static IP in the client devices? – AEonAX Apr 22 '15 at 4:24
  • I have tried that but I've found even setting the subnet mask and gateway correctly, and the IP in the correct range, yields no results. The phone still reports no clients and the laptop thinks it's connected to the network. – Daniel Apr 22 '15 at 4:26
  • How did you get the subnet mask and gateway? – AEonAX Apr 22 '15 at 4:31
  • I gathered these from the details it provides me when I tether via USB. From what I can remember from when WiFi tethering was working, these are generally the same for both interfaces. – Daniel Apr 22 '15 at 4:33
  • I have to ask, you did also try shutdown plus removing the battery. Also, if you connect the phone (as a client) to a wi-fi ap, does it work? – Dan Apr 22 '15 at 6:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.