0

I am experiencing problems with Samsung Galaxy Note 2.

  • Build number(ROM): DN4 v2.1
  • Baseband version: N7100NEUFND1
  • Android version: 4.4.4
  • Kernel: AGNI KERNEL (March 29,2015)

I have overclocked CPU from 1.6 GHZ to 2.0 GHZ and I use SetCPU app to control CPU values like:

  • When screen is off, change governor to Ondemand with min and max frequencies at 200 MHZ and 400 MHZ.
  • When screen is on, change governor to Performance with min and max frequencies at 1000 MHZ and 1800 MHZ.

The problem is that now whenever I set the values, the values drops down to 1200 MHZ and goes down to 500 MHZ gradually. Mostly, it stays stuck at 1000 MHZ causing the device to lag especially while gaming.

Previously, I experienced problems with all other governors except Performance, Pegasusq and Powersaver, even when I set the Max value to 1.8 GHZ it somehow restricted the Max frequency to 1.2 GHZ. Now I think this has affected all the governors.

I have also updated my kernel but the problem persists.

Any solutions?

  • 1
    Is your device getting hot during these points? Processors generally throttle themselves when they reach certain temperature levels, to prevent possibly damaging hardware components. Even if you cranked up the max CPU frequency, if the chip hits its thermal limit it's going to throttle. – eldarerathis Apr 23 '15 at 18:23
  • Sometimes it can also be the CPU hotplug that is restricting the frequency. I believe this is sometimes an issue with Qualcomm's MPDecision. Other CPU hotplugs such as IntelliPlug should work (don't use two hotplugs at once, whatever you do), however hotplugs are built into the kernel and a side-kernel can sometimes break/limit the functionality (not really brick) of your device. – Joe Oct 29 '15 at 21:37
1

Changing governors has never really worked for me. Basically one of the issues with clocking at higher speeds is that this draws more power, which causes the CPU temperature to spike. The systems recognises it, and automatically throttles the clock speeds down so the CPU doesn't cook itself.

I have exactly your setup, a Note 2 with DN4 v2.1 running AGNI kernel, and was facing this issue. In my experience the best performance i got was with the stock Pegasus governor, a 1.8ghz cpu ceiling @ a voltage of 1225mv (was 1350mv). The lower voltage meant that the CPU could sit at this higher clock speed for longer, so my benchmarks went up pretty dramatically. My Antutu went from 25307 to 30541, because it was able to stay at the higher clock speed before thermal throttling set in. Unfortunately you cannot set the voltages manually using the AGNI kernel, so i had to download an app called 'System Tuner'.

Slapping the CPU up to 2ghz is fine, but it can only run at this speed for a few seconds before the temperature goes through the roof. Better to sit at a slightly lower clock speed IMO.

Good luck!

| improve this answer | |
0

It's a bug on the power saving mode ~ just go to power saving mode and untick "restrict performance". Even when the power saving mode is not activated, the CPU frequency will still be kept below 1200 if you still keep the "restrict performance" on. So every time you enable power saving mode, remember to do this when you disable it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.